From 3ec4774bf40a3673935c0e87c917dab70751d33a Mon Sep 17 00:00:00 2001
From: William Pitcock <nenolod@dereferenced.org>
Date: Tue, 24 Jan 2017 03:16:05 +0000
Subject: [PATCH] main/gcc: powerpc: everyone is wrong, the real answer is
 --enable-decimal-float=no

---
 main/gcc/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 0ea202c3d7b1..6323f1bcc65c 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -242,7 +242,7 @@ build() {
 	armv6-*-*-*eabihf)	_arch_configure="--with-arch=armv6zk --with-tune=arm1176jzf-s --with-fpu=vfp --with-float=hard --with-abi=aapcs-linux";;
 	armv7-*-*-*eabihf)	_arch_configure="--with-arch=armv7-a --with-tune=generic-armv7-a --with-fpu=vfpv3-d16 --with-float=hard --with-abi=aapcs-linux --with-mode=thumb";;
 	mipsel-*-*-*)		_arch_configure="--with-arch-32=mips2 --with-tune-32=mips32 --with-fp-32=32 --with-mips-plt --with-float=hard --with-abi=32";;
-	powerpc-*-*-*)		_arch_configure="--with-long-double-128 --disable-softfloat";;
+	powerpc-*-*-*)		_arch_configure="--enable-secureplt --enable-decimal-float=no";;
 	i486-*-*-*)		_arch_configure="--with-arch=i486 --with-tune=generic --enable-cld";;
 	i586-*-*-*)		_arch_configure="--with-arch=i586 --with-tune=generic --enable-cld";;
 	s390x-*-*-*)		_arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;
-- 
GitLab