diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 0ea202c3d7b185628af0b858ee99fb4dda914c89..6323f1bcc65c558188073da34cc6d05bf7e46fce 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -242,7 +242,7 @@ build() {
 	armv6-*-*-*eabihf)	_arch_configure="--with-arch=armv6zk --with-tune=arm1176jzf-s --with-fpu=vfp --with-float=hard --with-abi=aapcs-linux";;
 	armv7-*-*-*eabihf)	_arch_configure="--with-arch=armv7-a --with-tune=generic-armv7-a --with-fpu=vfpv3-d16 --with-float=hard --with-abi=aapcs-linux --with-mode=thumb";;
 	mipsel-*-*-*)		_arch_configure="--with-arch-32=mips2 --with-tune-32=mips32 --with-fp-32=32 --with-mips-plt --with-float=hard --with-abi=32";;
-	powerpc-*-*-*)		_arch_configure="--with-long-double-128 --disable-softfloat";;
+	powerpc-*-*-*)		_arch_configure="--enable-secureplt --enable-decimal-float=no";;
 	i486-*-*-*)		_arch_configure="--with-arch=i486 --with-tune=generic --enable-cld";;
 	i586-*-*-*)		_arch_configure="--with-arch=i586 --with-tune=generic --enable-cld";;
 	s390x-*-*-*)		_arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;