diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index dc1e3b8fdbe7152537d91dd4fea1f53d665b9920..251c69a4c90628a2e13169300355a068c0d1835a 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -274,8 +274,10 @@ EOF
 	# Install a list of symlinks installed by busybox.  This is useful for
 	# building and analyzing Alpine-based images which contain busybox, where
 	# you don't want to run busybox --list-path at analysis or build time.
-	mkdir -p "$pkgdir"/etc/busybox-paths.d
-	"$pkgdir"/bin/busybox --list-path > "$pkgdir"/etc/busybox-paths.d/busybox
+	if [ "$CHOST" != "$CBUILD" ]; then
+		mkdir -p "$pkgdir"/etc/busybox-paths.d
+		"$pkgdir"/bin/busybox --list-path > "$pkgdir"/etc/busybox-paths.d/busybox
+	fi
 }
 
 extras() {
@@ -286,8 +288,10 @@ extras() {
 	# Install a list of symlinks installed by busybox-extras.  This is useful for
 	# building and analyzing Alpine-based images which contain busybox, where
 	# you don't want to run busybox --list-path at analysis or build time.
-	mkdir -p "$subpkgdir"/etc/busybox-paths.d
-	"$subpkgdir"/bin/busybox-extras --list-path > "$subpkgdir"/etc/busybox-paths.d/busybox-extras
+	if [ "$CHOST" != "$CBUILD" ]; then
+		mkdir -p "$subpkgdir"/etc/busybox-paths.d
+		"$subpkgdir"/bin/busybox-extras --list-path > "$subpkgdir"/etc/busybox-paths.d/busybox-extras
+	fi
 }
 
 suid() {