diff --git a/testing/ticker/APKBUILD b/testing/ticker/APKBUILD
index ab8ae1ba3101d387aa48f9453c42823685dee06d..2eee62f9013fb8aabe15c84e838871cd216f4b00 100644
--- a/testing/ticker/APKBUILD
+++ b/testing/ticker/APKBUILD
@@ -1,13 +1,18 @@
 # Contributor: Hoang Nguyen <folliekazetani@protonmail.com>
 # Maintainer: Hoang Nguyen <folliekazetani@protonmail.com>
 pkgname=ticker
-pkgver=4.5.3
+pkgver=4.5.4
 pkgrel=0
 pkgdesc="Terminal stock watcher and stock position tracker"
 url="https://github.com/achannarasappa/ticker"
 arch="all"
 license="GPL-3.0-or-later"
 makedepends="go"
+subpackages="
+	$pkgname-bash-completion
+	$pkgname-fish-completion
+	$pkgname-zsh-completion
+	"
 source="$pkgname-$pkgver.tar.gz::https://github.com/achannarasappa/ticker/archive/refs/tags/v$pkgver.tar.gz"
 
 export GOCACHE="$srcdir/go-cache"
@@ -15,7 +20,12 @@ export GOTMPDIR="$srcdir"
 export GOMODCACHE="$srcdir/go"
 
 build() {
-	go build -v -o bin/$pkgname -ldflags "-X github.com/achannarasappa/ticker/cmd.Version=v$pkgver"
+	go build -v -o bin/ticker \
+		-ldflags "-X github.com/achannarasappa/ticker/cmd.Version=v$pkgver"
+
+	./bin/ticker completion bash > ticker.bash
+	./bin/ticker completion zsh > ticker.zsh
+	./bin/ticker completion fish > ticker.fish
 }
 
 check() {
@@ -24,8 +34,15 @@ check() {
 
 package() {
 	install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+
+	install -Dm644 ticker.bash \
+		"$pkgdir"/usr/share/bash-completion/completions/ticker
+	install -Dm644 ticker.fish \
+		"$pkgdir"/usr/share/fish/completions/ticker.fish
+	install -Dm644 ticker.zsh \
+		"$pkgdir"/usr/share/zsh/site-functions/_ticker
 }
 
 sha512sums="
-75dc25feaa67342547edf346d20b6ed7f5c2022c620f33127c689ee8e4e377465cbb7be45a3005a48dc41e246029c68b75c833300761d2afd9f2f707e71d8a2b  ticker-4.5.3.tar.gz
+be69f9f03b5efbc9baf45ca7151d02ceb612e015b7db6bf328855372f8d83de337b15312c3507d94dcfd899ec11bb47d66a99ed9549ae0901fe41a2754a898eb  ticker-4.5.4.tar.gz
 "