diff --git a/community/lv2/APKBUILD b/community/lv2/APKBUILD
index be93ddfb5b0d34da6592e43e83f6733942cfe3df..2ee2d5b69b158a09bf0a5ad41f2b760dbdd35324 100644
--- a/community/lv2/APKBUILD
+++ b/community/lv2/APKBUILD
@@ -1,29 +1,34 @@
 # Contributor: David Demelier <markand@malikania.fr>
 # Maintainer: David Demelier <markand@malikania.fr>
 pkgname=lv2
-pkgver=1.18.4
+pkgver=1.18.8
 pkgrel=0
 pkgdesc="extensible open standard for audio plugins"
 url="https://lv2plug.in"
 arch="all"
 license="ISC"
-makedepends="python3 gtk+2.0-dev libsndfile-dev gcovr"
+makedepends="
+	gtk+2.0-dev
+	libsamplerate-dev
+	libsndfile-dev
+	meson
+	"
 subpackages="$pkgname-dev"
-source="http://lv2plug.in/spec/lv2-$pkgver.tar.bz2"
+source="https://lv2plug.in/spec/lv2-$pkgver.tar.xz"
 
 build() {
-	python3 waf configure --prefix=/usr -T
-	python3 waf build
+	abuild-meson . output
+	meson compile -C output
 }
 
 check() {
-	python3 waf test
+	meson test --print-errorlogs --no-rebuild -C output
 }
 
 package() {
-	python3 waf install --destdir="$pkgdir"
+	DESTDIR="$pkgdir" meson install --no-rebuild -C output
 }
 
 sha512sums="
-8095a1f3dcf70cf8cefff18c40b52c1dffeab0fe1f6bfb083c9f0e48a9617d3c8647b3f4db567ac1f5f33564399ffe1023774ad9bacb1bb0133f182422f22d6a  lv2-1.18.4.tar.bz2
+9925290818bd683200bc738e3e9342b946fe82a04d983e89c240ae70b9053a7a59a8d505c522fe7af5b804adeba00fdf94403bd34844ce11e26cc1ff62c2f254  lv2-1.18.8.tar.xz
 "