diff --git a/testing/waylock/APKBUILD b/testing/waylock/APKBUILD
index 543fccb1c46439a040067622f96ffee6e9f1f11d..8ec016c3be851a1305e8352e495d1f173c17e6af 100644
--- a/testing/waylock/APKBUILD
+++ b/testing/waylock/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Jakub Jirutka <jakub@jirutka.cz>
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=waylock
-pkgver=0.6.4
+pkgver=0.6.5
 pkgrel=0
 pkgdesc="A small screenlocker for Wayland compositors"
 url="https://codeberg.org/ifreund/waylock"
@@ -17,6 +17,7 @@ makedepends="
 	"
 subpackages="$pkgname-doc"
 source="https://codeberg.org/ifreund/waylock/releases/download/v$pkgver/waylock-$pkgver.tar.gz
+	fix-version-string.patch
 	pam-base-auth.patch
 	"
 
@@ -36,6 +37,7 @@ package() {
 }
 
 sha512sums="
-c663223cdfd99c4bc730ae06d75c4a8e75f068f07245d15fa7c463e468b2dcfaae2e8a46f83f380cc4b86059045337ed00b1eae223bc4ea67058831f6f6febd0  waylock-0.6.4.tar.gz
+1a158205c12c51946178ede06eded9f54aff03aefdb5c3e306b1570ef786a611405cfcb96bafb4bd29a82016077fce0630c406d56431ad7dc5cbfb9a5696b589  waylock-0.6.5.tar.gz
+c1782ce8f6e2a2eab4bc5cdfdba22e0e9b14e89c319737bd0c331a9b8c4b09cc9debafa33c6936631f6db14331ebecf0d327dc05d8c8a77a36ef45de35639750  fix-version-string.patch
 e3f5aa479908babbeea2febecdf7c57a5cf6b9153c4cd63731721cdf6d50bd0417077b37effec1520064918a422c4313d24ee9c2b2a77c328be931ffbeb03161  pam-base-auth.patch
 "
diff --git a/testing/waylock/fix-version-string.patch b/testing/waylock/fix-version-string.patch
new file mode 100644
index 0000000000000000000000000000000000000000..d2d345f3fce5e8b815d1e40acb37670c8a3196fe
--- /dev/null
+++ b/testing/waylock/fix-version-string.patch
@@ -0,0 +1,15 @@
+This is a bug with the waylock 0.6.5 release tarball. The Git tag for 0.6.5
+does not have this problem. This patch can be removed on the next release.
+
+diff -upr waylock-0.6.5.orig/build.zig waylock-0.6.5/build.zig
+--- waylock-0.6.5.orig/build.zig	2024-03-03 10:47:47.439903112 +0100
++++ waylock-0.6.5/build.zig	2024-03-03 10:47:55.963263085 +0100
+@@ -10,7 +10,7 @@ const Scanner = @import("deps/zig-waylan
+ /// development with the "-dev" suffix.
+ /// When a release is tagged, the "-dev" suffix should be removed for the commit that gets tagged.
+ /// Directly after the tagged commit, the version should be bumped and the "-dev" suffix added.
+-const version = "0.6.6-dev";
++const version = "0.6.5";
+ 
+ pub fn build(b: *Build) !void {
+     const target = b.standardTargetOptions(.{});