diff --git a/testing/templ/APKBUILD b/testing/templ/APKBUILD
index 502b69e1053941a9e0fa0fe992f2f9243a31e433..40425b70829746a63c16ee2e363b0c0e7bdfe80a 100644
--- a/testing/templ/APKBUILD
+++ b/testing/templ/APKBUILD
@@ -1,17 +1,22 @@
 # Maintainer: Hoang Nguyen <folliekazetani@protonmail.com>
 pkgname=templ
-pkgver=0.2.543
+pkgver=0.2.598
 pkgrel=0
 pkgdesc="Language for writing HTML user interface in Go"
 url="https://templ.guide/"
-# 32-bit: fail to build
-arch="all !x86 !armhf !armv7"
+arch="all"
 license="MIT"
 makedepends="go"
+checkdepends="gopls"
 source="$pkgname-$pkgver.tar.gz::https://github.com/a-h/templ/archive/refs/tags/v$pkgver.tar.gz"
 options="net" # download Go modules
 
-export CGO_ENABLED=0
+# /cmd/templ/lspcmd: hangs on s390x
+# /cmd/templ/generatecmd/testwatch: panics on 32-bit platforms (unaligned 64-bit atomic operation)
+case "$CARCH" in
+	s390x|x86|armhf|armv7) options="$options !check";;
+esac
+
 export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
 export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
 export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
@@ -31,5 +36,5 @@ package() {
 }
 
 sha512sums="
-7024a18184a3eca4c1a6f502ae8ab99b9a7ff0ce5727d2cd586afabddbb315915891cf01e536ea5cb8e1dba71c48bf81ce90313be1bc3e16da81e542d9996b94  templ-0.2.543.tar.gz
+7c7988e27498e391701c7df29663c3a44c2a50f97ea668a6fd84e54ee30dd47f3c52fe904f27b0dd184718f5518bee284e4899da48e6a00109691eaa65da6092  templ-0.2.598.tar.gz
 "