Commit fb87c0a9 authored by TBK's avatar TBK Committed by Leo
Browse files

community/mumble: fix murmur-openrc subpkg

Fix so murmur pkg will automatically install murmur-openrc.
parent db898591
......@@ -17,9 +17,10 @@ makedepends="qt5-qtbase-dev libsndfile-dev boost-dev avahi-dev protobuf-dev
install="murmur.pre-install"
pkgusers="murmur"
pkggroups="murmur"
subpackages="$pkgname-doc murmur murmur-openrc:murmur_openrc:noarch murmur-doc:murmur_doc:noarch"
subpackages="$pkgname-doc murmur murmur-openrc murmur-doc:murmur_doc:noarch"
source="https://github.com/mumble-voip/mumble/releases/download/$pkgver/mumble-$pkgver.tar.gz
murmur.initd"
murmur.initd
"
# secfixes:
# 1.2.19-r9:
......@@ -66,6 +67,9 @@ package() {
# Man pages.
mkdir -p "$pkgdir"/usr/share/man/man1/
install -m644 ./man/mum* "$pkgdir"/usr/share/man/man1/
# openrc service
install -Dm755 "$srcdir"/murmur.initd "$pkgdir"/etc/init.d/murmur
}
murmur() {
......@@ -91,11 +95,6 @@ murmur() {
-i "$subpkgdir"/etc/dbus-1/system.d/murmurd.conf
}
murmur_openrc() {
install -Dm755 "$srcdir"/murmur.initd \
"$subpkgdir"/etc/init.d/murmur
}
murmur_doc() {
pkgdesc="Murmur is the server component of Mumble"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment