Commit 03f4778d authored by Leo's avatar Leo
Browse files

testing/rabbitmq-server: upgrade to 3.8.10

parent eeb2a97c
# Contributor: Nathan Johnson <nathan@nathanjohnson.info>
# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
pkgname=rabbitmq-server
pkgver=3.8.9
pkgver=3.8.10
pkgrel=0
pkgdesc="RabbitMQ is an open source multi-protocol messaging broker."
url="https://www.rabbitmq.com/"
......@@ -19,7 +19,6 @@ source="
rabbitmq-server.logrotate
https://github.com/rabbitmq/rabbitmq-server/releases/download/v$pkgver/rabbitmq-server-$pkgver.tar.xz
py3.patch
list-elixir-1.11-as-supported.patch
"
options="!check" # test suite broken
......@@ -78,6 +77,5 @@ package() {
sha512sums="a8bb02a7cae1f8720e5c7aaabfe6a2c0e731cffbe0d8f99bdcb6597daa654dc49e6d41943974601435700cf469eaa8286dc91a3255a6b9023754c3861fbb5cd9 rabbitmq-server.initd
b8655cb048ab3b32001d4e6920bb5366696f3a5da75c053605e9b270e771c548e36858dca8338813d34376534515bba00af5e6dd7b4b1754a0e64a8fb756e3f3 rabbitmq-server.logrotate
11e041235280c23012d967c6dbd78d1fc95a312fe1acb3aa51a7ed8731cc8c26acbcd7272a8100b8a5d75f49d38466980be194c6013921b017ed6fd09eb5ee55 rabbitmq-server-3.8.9.tar.xz
6b7f065bb0482777b88a7bf9d1cfea77c2248af7a11e4792ab56049ae6d195fa232b56311c9ef90885186898db27b4d15da02ccbd831aa0d5edcab5ef9770f3a py3.patch
29538a2760b23ddb5b398492aabcba7acc407d6372d54113604d826632e6277fc314e6bc4feb7bdcff7bed66a6a9da76567ed80845645f2c93fef9acf82f6911 list-elixir-1.11-as-supported.patch"
343d9228c6dc26f9e2974ed0fc589ccf78ff9841b8492962ff91342a2b8e2fad484c45444716e511df2f54b2134b33c99f3d3c05f603173428ea04216285f30a rabbitmq-server-3.8.10.tar.xz
6b7f065bb0482777b88a7bf9d1cfea77c2248af7a11e4792ab56049ae6d195fa232b56311c9ef90885186898db27b4d15da02ccbd831aa0d5edcab5ef9770f3a py3.patch"
From d7824289f40aeaa221f401007ab195ba599d94e3 Mon Sep 17 00:00:00 2001
From: Michael Klishin <michael@clojurewerkz.org>
Date: Tue, 20 Oct 2020 13:28:58 +0300
Subject: [PATCH] List Elixir 1.11 as supported
---
deps/rabbitmq_cli/mix.exs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/deps/rabbitmq_cli/mix.exs b/deps/rabbitmq_cli/mix.exs
index 7f531d0757a..3f542e49b09 100644
--- a/deps/rabbitmq_cli/mix.exs
+++ b/deps/rabbitmq_cli/mix.exs
@@ -11,7 +11,7 @@ defmodule RabbitMQCtl.MixfileBase do
[
app: :rabbitmqctl,
version: "3.8.0-dev",
- elixir: ">= 1.8.0 and < 1.11.0",
+ elixir: ">= 1.10.4 and < 1.12.0",
build_embedded: Mix.env == :prod,
start_permanent: Mix.env == :prod,
escript: [main_module: RabbitMQCtl,
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment