Commit f8938137 authored by Leo's avatar Leo

community/vlc: upgrade to 3.0.8

parent 7ab0da78
......@@ -2,8 +2,8 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vlc
pkgver=3.0.7.1
pkgrel=2
pkgver=3.0.8
pkgrel=0
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
triggers="vlc-libs.trigger=/usr/lib/vlc/plugins"
pkgusers="vlc"
......@@ -113,13 +113,12 @@ makedepends="
samba-dev
gnutls-dev
"
source="https://get.videolan.org/vlc/$pkgver/$pkgname-$pkgver.tar.xz
source="https://get.videolan.org/vlc/$pkgver/vlc-$pkgver.tar.xz
omxil-rpi-codecs.patch
check-headless.patch
disable-sub-autodetect-fuzzy-1-test.patch
test-s390x.patch
fribidi_allow_deprecated.patch
CVE-2019-13602.patch
"
# secfixes:
......@@ -327,10 +326,9 @@ plugins_video_filter() { _mv_plugins video_filter; }
plugins_video_output() { _mv_plugins video_output; }
plugins_visualization() { _mv_plugins visualization; }
sha512sums="6b99ae0564630a7a7ca9187c3bb954c601e384522ce93460b73f2dbf31787ce5828daca9f31c781b97db77872d76b6a3e871ff3401d70f1b5829fee7c4e847fd vlc-3.0.7.1.tar.xz
sha512sums="5ade0b350e98fd6fa90035bffabda96f0addb3844a7c0a242b4db1cab6a746e1adb1d713ddcb48ae51a7d1736090f096f5d3b0637a9f958ccf4fcf27e838cf70 vlc-3.0.8.tar.xz
e13e398b7bfd977f6e099bcb6cf8dc5cd5bad6dea3eff715881826246dc4329468846084aff2576de2b7fd28d3f06e7c327a6e4511a28d22e5cd198a81146c89 omxil-rpi-codecs.patch
22d80df599b8b65a5439cefbb7140af8e9530f326d54945da3769af65f37518b99ec2cc8647aafd2763324a0698280915afe043cc87e5720c4694881ed35bffa check-headless.patch
e214b407235cb3afb8bec93f20c9b42957b57e6fd3960679d3d4235e77762e03e64d03c01f00ef63d589e7c85aaad02ce6abbeeccd66b1867bc92451a5b5e9b0 disable-sub-autodetect-fuzzy-1-test.patch
c0107655249687655846a9547ca1a5670b9207443180600e7a149c69ffb96d7226787c19b018d4033db9b284c1a5faa8d7d42188ed40c3b8bb051256febf11c5 test-s390x.patch
8230a83306905cdda07fecdb6cb2b791196034775cc5c8986ab63e97cd3476317544011cbce92948059ac9f7b57ef450cd71820f0f134bc3ab3bed38463a67c3 fribidi_allow_deprecated.patch
40dd07023f7ebc769d4aa3f03b8d4b0cb3e98fd2548564ff3e891c717d798ab07a9a772e10db8378e6ca9265a2ec04bb6c516394803a6ae2d2f523ee5fea8f9e CVE-2019-13602.patch"
8230a83306905cdda07fecdb6cb2b791196034775cc5c8986ab63e97cd3476317544011cbce92948059ac9f7b57ef450cd71820f0f134bc3ab3bed38463a67c3 fribidi_allow_deprecated.patch"
diff --git a/modules/demux/mp4/mp4.c b/modules/demux/mp4/mp4.c
index edda423..b2e3863 100644
--- a/modules/demux/mp4/mp4.c
+++ b/modules/demux/mp4/mp4.c
@@ -421,11 +421,11 @@ static block_t * MP4_EIA608_Convert( block_t * p_block )
block_t *p_newblock;
/* always need at least 10 bytes (atom size+header+1pair)*/
- if ( i_remaining < 10 ||
- !(i_bytes = GetDWBE(p_block->p_buffer)) ||
- (i_bytes > i_remaining) ||
- memcmp("cdat", &p_block->p_buffer[4], 4) ||
- !(p_newblock = block_Alloc( i_remaining * 3 - 8 )) )
+ i_bytes = GetDWBE(p_block->p_buffer);
+
+ if (10 < i_bytes || i_bytes < i_remaining ||
+ memcmp("cdat", &p_block->p_buffer[4], 4) ||
+ (p_newblock = block_Alloc(i_remaining * 3 - 8)) == NULL)
{
p_block->i_buffer = 0;
return p_block;
@@ -447,10 +447,11 @@ static block_t * MP4_EIA608_Convert( block_t * p_block )
} while( i_bytes >= 2 );
/* cdt2 is optional */
- if ( i_remaining >= 10 &&
- (i_bytes = GetDWBE(p_read)) &&
- (i_bytes <= i_remaining) &&
- !memcmp("cdt2", &p_read[4], 4) )
+ i_bytes = GetDWBE(p_block->p_buffer);
+
+ if (10 < i_bytes || i_bytes < i_remaining ||
+ memcmp("cdat", &p_block->p_buffer[4], 4) ||
+ (p_newblock = block_Alloc(i_remaining * 3 - 8)) == NULL)
{
p_read += 8;
i_bytes -= 8;
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment