Commit f65d3371 authored by Leo's avatar Leo

community/libblockdev: upgrade to 2.23

parent 61d4ab43
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=libblockdev
pkgver=2.22
pkgver=2.23
pkgrel=0
pkgdesc="Library for manipulating block devices"
url="https://github.com/storaged-project/libblockdev"
......@@ -11,7 +11,7 @@ makedepends="python3 cryptsetup-dev libbytesize-dev ndctl-dev lvm2-dev
glib-dev kmod-dev parted-dev nss-dev yaml-dev coreutils eudev-dev
dmraid-dev volume_key-dev bash gobject-introspection-dev"
subpackages="$pkgname-dev py3-$pkgname:_py3:noarch"
source="https://github.com/storaged-project/libblockdev/releases/download/${pkgver}-1/libblockdev-${pkgver}.tar.gz
source="https://github.com/storaged-project/libblockdev/releases/download/$pkgver-1/libblockdev-$pkgver.tar.gz
fix-glibc-glob-onlydir.patch"
build() {
......@@ -40,5 +40,5 @@ _py3() {
mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib
}
sha512sums="69bbd5afbd8abb0e22ef72d80375e32db653f21cf3063cf69fff71ad069ee0e6119adf6918a63e7ba9ec4ca02ffe3337be3edeeafdd3e73e4e53d85e90bf2f45 libblockdev-2.22.tar.gz
sha512sums="ecc4d5a3cb977fbbe176bf6872b6754833d2869e927c32f8466685916ee4550cf806e0b0c8f5e8e76de3839ae591a4eec502ff974c2f0678af6cfd46dd3016f3 libblockdev-2.23.tar.gz
199b184b2955a49320f2d8dd71be31507f170a21652c8dbc5d2821b5a451d8252402c4a14f8c0cef6b95c8a9ae85a6f385d5b9720d2d683b3b41fe1a056fc438 fix-glibc-glob-onlydir.patch"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment