Commit ebcbfd35 authored by Natanael Copa's avatar Natanael Copa

main/lua-expat: add support for Lua 5.3 and use install_if

parent 50c6eba5
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
_luaversions="5.1 5.2"
_luaversions="5.1 5.2 5.3"
pkgname=lua-expat
_name=expat
pkgver=1.3.0
pkgrel=1
pkgrel=2
pkgdesc="SAX XML parser based on the Expat library"
url="https://matthewwild.co.uk/projects/luaexpat/"
arch="all"
......@@ -17,7 +17,6 @@ subpackages=
for _i in $_luaversions; do
makedepends="$makedepends lua${_i}-dev"
subpackages="$subpackages lua${_i}-$_name:_split${_i/./}"
depends="$depends lua${_i}-$_name"
done
source="http://matthewwild.co.uk/projects/luaexpat/luaexpat-$pkgver.tar.gz"
......@@ -44,6 +43,7 @@ package() {
_split() {
local d= _ver=$1
pkgdesc="$pkgdesc for Lua $_ver"
install_if="lua$_ver $pkgname=$pkgver-r$pkgrel"
depends=
for d in usr/lib/lua usr/share/lua; do
if [ -d "$pkgdir"/$d/$_ver ]; then
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment