Commit d2319f44 authored by Roberto Oliveira's avatar Roberto Oliveira

main/confuse: security upgrade to 3.2.2

- CVE-2018-14447
parent 50bb5f87
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=confuse
pkgver=3.2.1
pkgver=3.2.2
pkgrel=0
pkgdesc="C library for parsing configuration files"
url="https://github.com/martinh/libconfuse"
......@@ -12,6 +12,10 @@ source="https://github.com/martinh/libconfuse/releases/download/v$pkgver/confuse
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 3.2.2-r0:
# - CVE-2018-14447
build() {
cd "$builddir"
./configure \
......@@ -35,4 +39,4 @@ package() {
install -D -m644 libconfuse.pc "$pkgdir"/usr/lib/pkgconfig/libconfuse.pc
}
sha512sums="738bacf6a3abb9c64666fec103eb18c8456b994e7ba3562bdb090ef4eb33f0330da844de14d658ef44e74f90104f67ceaf408d21ddf0d251f4c6ddd80e0b387c confuse-3.2.1.tar.xz"
sha512sums="c6baea65e064fe7f2d1bde187c6dcbb7f03c31f5d777cb04576f9cc2d94e9c96b7ee202e030e9a2c7eb619deb240d9e76fb12b3528ae5aa0d3abe231354d12c9 confuse-3.2.2.tar.xz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment