Commit b001493f authored by Jakub Jirutka's avatar Jakub Jirutka

community/jruby: upgrade to 9.2.0.0

Removed subpackages for bundled gems are not included in JRuby anymore.
parent e600734d
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=jruby
pkgver=9.1.14.0
pkgver=9.2.0.0
pkgrel=0
pkgdesc="An implementation of Ruby on the JVM"
url="http://jruby.org"
......@@ -11,15 +11,10 @@ license="EPL GPL-2.0 LGPL-2.1 custom"
depends="$pkgname-libs java-jffi-native>=1.2 libc6-compat>=1.1.12-r5 openjdk8-jre-base"
makedepends="openjdk8 zip"
subpackages="
$pkgname-did_you_mean
$pkgname-irb
$pkgname-minitest
$pkgname-net-telnet:net_telnet
$pkgname-power_assert
$pkgname-rake
$pkgname-rdoc
$pkgname-readline
$pkgname-test-unit:test_unit
$pkgname-libs"
# jruby (launch script): https://github.com/jruby/jruby/pull/1860
source="https://s3.amazonaws.com/jruby.org/downloads/$pkgver/$pkgname-bin-$pkgver.tar.gz
......@@ -35,7 +30,7 @@ _stdlibdir="$_rubydir/stdlib"
prepare() {
cd "$builddir"/bin
rm *.bat *.dll *.exe
rm jirb_swing jruby jruby200.sh jruby.*
rm jirb_swing jruby jruby200.sh jruby.* testrb
cd "$builddir"/lib/ruby/stdlib
rm -r win32 Win32API.rb
......@@ -76,13 +71,6 @@ package() {
install -m644 -D COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
did_you_mean() {
pkgdesc="Did you mean? experience in JRuby"
depends="$pkgname"
_mvgem did_you_mean
}
irb() {
pkgdesc="Interactive JRuby console"
depends="$pkgname $pkgname-readline"
......@@ -91,27 +79,6 @@ irb() {
_mv $_bindir/irb usr/bin/jirb
}
minitest() {
pkgdesc="Ruby testing tool supporting TDD, BDD, mocking, and benchmarking"
depends="$pkgname"
_mvgem minitest
}
net_telnet() {
pkgdesc="Telnet client functionality for JRuby"
depends="$pkgname"
_mvgem net-telnet
}
power_assert() {
pkgdesc="Power Assert for JRuby"
depends="$pkgname"
_mvgem power_assert
}
rake() {
pkgdesc="Ruby based make-like utility."
depends="$pkgname"
......@@ -132,18 +99,11 @@ readline() {
pkgdesc="Readline support for JRuby"
depends="$pkgname java-jansi-native"
_mvgem jruby-readline
_mv $_stdlibdir/jline
mv "$pkgdir"$_stdlibdir/readline* "$subpkgdir"$_stdlibdir/
}
test_unit() {
pkgdesc="Legacy xUnit family unit testing framework for JRuby"
depends="$pkgname $pkgname-power_assert"
_mvgem test-unit
_mv $_stdlibdir/test $_bindir/testrb
}
libs() {
pkgdesc="JRuby's standard libraries"
depends=""
......@@ -173,5 +133,5 @@ _mvgem() {
done
}
sha512sums="d15ae0c60421951b830524acd21a0f2a56f480e983b148a2722cd36afed8e99a41f518eb8a679bfa2cf87f08637e81c24ea88be40c0a5390e081322f1fc6f8da jruby-bin-9.1.14.0.tar.gz
sha512sums="79f5e8674089d2f6b260e033e3ceb4571f54cb5cedbca74ba76b52dd7cb30085a8c6c2676e9be57a8ecd9e962fbcb3682a8de38e1cdde2dc6e05bd179556edc3 jruby-bin-9.2.0.0.tar.gz
f2906a0136f437eaa119eae26d93b1a8e3411bc4ccee9453debf7a5d57bce767100b36a660db42184fd8398ff258455c3f2a8ef1082c907285b48d1b9b218bc2 jruby"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment