Commit 8643f032 authored by Natanael Copa's avatar Natanael Copa

main/acf-core: update lua-json4 depends

commit 66573786 (main/lua-json4: install into lua/common, remove
subpkgs, add rock_manifest) renamed the lua5.x-json4 packages and added
a provides for backwards compatibility. But the build time dependencies
does not resolve the provides so builder will fail figure out the build
time order.

We work aorund this by adding an explicit depend of lua-json4, without
the lua version, so we no longer depend on proper provides resolving.
parent 8dc0e43d
......@@ -3,14 +3,14 @@
_luaversion="5.2"
pkgname=acf-core
pkgver=0.21.1
pkgrel=0
pkgrel=1
pkgdesc="A web-based system administration interface framework"
url="https://git.alpinelinux.org/cgit/acf/acf-core"
arch="noarch"
license="GPL-2.0"
install="$pkgname.post-upgrade"
depends="acf-jquery acf-lib acf-skins haserl-lua$_luaversion lua$_luaversion
lua$_luaversion-posix lua$_luaversion-md5 lua$_luaversion-json4
lua$_luaversion-posix lua$_luaversion-md5 lua-json4
lua$_luaversion-subprocess"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment