Commit 8558124e authored by Leo's avatar Leo

testing/lua-linenoise: upgrade to 0.9

parent f65d3371
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua-linenoise
pkgver=0.8
pkgver=0.9
pkgrel=0
pkgdesc="Lua bindings for linenoise"
url="https://github.com/hoelzro/lua-linenoise"
arch="all"
license="MIT"
makedepends="linenoise-dev"
subpackages=""
source="lua-linenoise-$pkgver.tar.gz::https://github.com/hoelzro/lua-linenoise/archive/$pkgver.tar.gz"
builddir="$srcdir/lua-linenoise-$pkgver"
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
subpackages="$subpackages lua${_v}-${pkgname#lua-}:_subpackage"
makedepends="$makedepends lua${_v}-dev"
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
makedepends="$makedepends lua$_v-dev"
done
build() {
......@@ -39,7 +37,7 @@ _subpackage() {
install_if="$pkgname=$pkgver-r$pkgrel $lua"
install -m 644 -D "$srcdir"/build-$lver/linenoise.so \
"$subpkgdir"/usr/lib/lua/${lver}/linenoise.so
"$subpkgdir"/usr/lib/lua/$lver/linenoise.so
}
sha512sums="7d4476570a3de054916047e201f8eabf2f1d4f8c0a6a5fa492dd477c580c81607a536a79c7a73a7f63ceeda0d6554a41f4f353ae34bb1d978679bc0aa5a757c4 lua-linenoise-0.8.tar.gz"
sha512sums="24cecd36329f74f36026c81afe1b7a9a3213d35c9cdc433e21f45bc4867be9537d61807ecb7344d789585a80a06c4f4d2de2412aab130e84adf817b56ecd0ea5 lua-linenoise-0.9.tar.gz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment