Commit 84db8330 authored by Leo's avatar Leo Committed by Natanael Copa

main/faad2: upgrade to 2.8.8

parent 311d20bd
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=faad2
pkgver=2.7
pkgrel=8
pkgver=2.8.8
pkgrel=0
pkgdesc="ISO AAC audio decoder"
url="http://www.audiocoding.com/"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+"
subpackages="$pkgname-dev $pkgname-doc"
depends=
license="GPL-2.0-or-later"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-libs"
makedepends="autoconf automake libtool"
source="https://downloads.sourceforge.net/sourceforge/faac/$pkgname-$pkgver.tar.bz2
automake.patch"
source="https://downloads.sourceforge.net/sourceforge/faac/$pkgname-$pkgver.tar.gz"
prepare() {
cd "$builddir"
update_config_sub
default_prepare
}
build() {
cd "$builddir"
# manfile has bad name
mv frontend/faad.man frontend/faad.1 && \
sed -i -e 's:faad\.man:faad.1:' frontend/Makefile.am
sh bootstrap
autoreconf -fi
}
build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
......@@ -35,10 +30,14 @@ build() {
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
install -m644 common/mp4ff/mp4ff_int_types.h "$pkgdir"/usr/include/mp4ff_int_types.h
}
sha512sums="0934aa9b752b5d86879d94156dea02595e2428340d0cf44202ffea369895b21a9aadbb4833a39212c9a79429b409eb108706b1f523bfddd32809b53730d50947 faad2-2.7.tar.bz2
0b66cfa240529a2139b47cb8dc87c4b43a451b906d66ef7d211fb509358b1493ceee13894516c2f552b33eae74640910e97957caa49dade2597ebd9777152a9e automake.patch"
static() {
depends=""
pkgdesc="$pkgdesc (static libraries)"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
}
sha512sums="3275d292b2a9fe984842962f4d81202894bddd17033f7cd6df95466554cc968dfcbf2890ae8b1df37da0cd25d645cca0a687f07e39b9fc37dd004fd5956a82af faad2-2.8.8.tar.gz"
--- ./configure.in.orig 2012-12-31 10:42:26.394219312 +0000
+++ ./configure.in 2012-12-31 10:42:43.294360781 +0000
@@ -25,7 +25,7 @@
AC_PROG_MAKE_SET
AC_CHECK_PROGS(RPMBUILD, rpmbuild, rpm)
-AM_CONFIG_HEADER(config.h)
+AC_CONFIG_HEADER(config.h)
AC_ARG_WITH(xmms,[ --with-xmms compile XMMS-1 plugin],
WITHXMMS=$withval, WITHXMMS=no)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment