Commit 7561c6a9 authored by Kevin Daudt's avatar Kevin Daudt

testing/py-jedi: drop python2 support

py-jedi is currently only used by ipython, which is only built for
python3.
parent 26aff493
......@@ -8,38 +8,17 @@ pkgdesc="Awesome autocompletion and static analysis library for python"
url="https://pypi.org/project/jedi"
arch="noarch"
license="MIT"
makedepends="py-setuptools python2-dev python3-dev"
subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
makedepends="py3-setuptools python3-dev"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py3-jedi"
build() {
cd "$builddir"
python2 setup.py build
python3 setup.py build
}
package() {
mkdir -p "$pkgdir"
}
_py2() {
replaces="$pkgname"
_py python2
}
_py3() {
_py python3
}
_py() {
local python="$1"
pkgdesc="$pkgdesc (for $python)"
depends="$depends $python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="b20fc75d909f9b7c6db434f468e7cefd9768991ca72d7026df9c4000805675a979f9e40f75623770df44bf8919a46270bcaa8e28d991a2299c64bc4c60d873fc jedi-0.13.3.tar.gz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment