Commit 43f6a694 authored by Jakub Jirutka's avatar Jakub Jirutka

main/lua-lyaml: install minimal rock_manifest

parent 109fe2c6
......@@ -2,7 +2,7 @@
_pkgname=lyaml
pkgname=lua-$_pkgname
pkgver=6.1.3
pkgrel=0
pkgrel=1
pkgdesc="LibYAML binding for Lua"
url="https://github.com/gvvaughan/lyaml"
arch="all"
......@@ -40,11 +40,15 @@ _subpackage() {
pkgdesc="$pkgdesc $lver"
depends="lua$lver"
install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
local rockdir="$subpkgdir/usr/lib/luarocks/rocks-$lver/$_pkgname/$pkgver-1"
cd "$srcdir"/build-$lver
lua$lver build-aux/luke PREFIX="$subpkgdir"/usr install
rm -Rf "$subpkgdir"/usr/share/doc
mkdir -p "$rockdir"
echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
sha512sums="aa101680b181d733c8648e0c800aa381c426483dc1ff59b80a6d2a3c7a058aa27e2783849da0aaaaf323c01dc891626ff194c3a86937b47ab1a5418e89128be4 lyaml-6.1.3.tar.gz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment