Commit 3b727fed authored by Natanael Copa's avatar Natanael Copa

main/cmake: upgrade to 2.8.0

parent 1aa565ac
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cmake
pkgver=2.6.4
pkgrel=1
pkgver=2.8.0
pkgrel=0
pkgdesc="CMake is a cross-platform open-source make system"
url="http://www.cmake.org"
license="CMake"
depends="uclibc libgcc g++ ncurses"
depends=
makedepends="ncurses-dev"
source="http://www.$pkgname.org/files/v2.6/$pkgname-$pkgver.tar.gz"
source="http://www.$pkgname.org/files/v${pkgver%.*}/$pkgname-$pkgver.tar.gz"
subpackages="$pkgname-doc"
......@@ -26,15 +26,20 @@ build ()
cd $startdir/src/$pkgname-$pkgver
# bug in cmake.
# http://www.mail-archive.com/cmake@cmake.org/msg09515.html
export CC="gcc"
export CXX="g++"
# export CC="gcc"
# export CXX="g++"
./bootstrap --prefix=/usr \
--mandir=/share/man \
--docdir=/share/cmake-2.6/doc \
--docdir=/share/cmake-${pkgver%.*}/doc \
$(parallel_opt)
make || return 1
}
package() {
cd $startdir/src/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
md5sums="50f387d0436696c4a68b5512a72c9cde cmake-2.6.4.tar.gz"
md5sums="3b3679b8a6afaedc38a8c15dd7ff4fcf cmake-2.8.0.tar.gz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment