Commit 317c2da5 authored by Leo's avatar Leo Committed by Natanael Copa

main/gconf: modernize

- Fix license
- Disable obsolete orbit support
- enable gsettings
- disable static library
parent 1f68b7fa
# Contributor:
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gconf
pkgver=3.2.6
pkgrel=4
pkgrel=5
pkgdesc="GNOME configuration system"
url="http://projects.gnome.org/gconf"
arch="all"
license="GPL-2.0+"
depends=
depends_dev="libxml2-dev gtk+3.0-dev polkit-dev orbit2-dev"
license="GPL-2.0-or-later"
depends_dev="libxml2-dev gtk+3.0-dev polkit-dev"
makedepends="$depends_dev gobject-introspection-dev glib-dev intltool"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/GConf/${pkgver%.*}/GConf-${pkgver}.tar.xz"
......@@ -22,7 +20,10 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc
--sysconfdir=/etc \
--disable-static \
--disable-orbit \
--enable-gsettings-backend
make
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment