Unverified Commit 278a13b7 authored by Leo's avatar Leo Committed by prs pkt

testing/py-apitree: Remove

- Python2 only
- Doesn't specify other dependencies so it doesn't actually work
- Upstream is dead
parent 712e7848
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-apitree
_pkgname=apitree
pkgver=0.3.3
pkgrel=0
pkgdesc="A Python web service API backend"
url="https://github.com/jmatthias/apitree"
arch="noarch"
license="BSD"
depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
}
build() {
cd "$_builddir"
python2 setup.py build || return 1
}
package() {
cd "$_builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
md5sums="05c0eb702054a27b5cf552bfbcad646d apitree-0.3.3.tar.gz"
sha256sums="315a9e60df0f861778acf6f95dcedd09115327460055164db253240a6621b437 apitree-0.3.3.tar.gz"
sha512sums="9fbefb1112fce2486c40ffda62d4548f262d1a064cb5ac3ce0eb3c5ef9f76c5cc1c793a6dfac6c8d112435fc8dd515cb6d4ffa2a77075600fe828cb530f95cbc apitree-0.3.3.tar.gz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment