Commit 19354120 authored by Leonardo Arena's avatar Leonardo Arena

main/irssi: security upgrade to 1.0.3 (CVE-2017-9468, CVE-2017-9469)

Fixes #7395
parent 37de56f4
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=irssi
pkgver=1.0.2
pkgrel=1
pkgver=1.0.3
pkgrel=0
pkgdesc="A modular textUI IRC client with IPv6 support"
url="http://irssi.org/"
arch="all"
......@@ -9,9 +9,13 @@ license="GPL2+"
makedepends="glib-dev libressl-dev ncurses-dev perl-dev automake autoconf libtool"
subpackages="$pkgname-doc $pkgname-dev $pkgname-proxy $pkgname-perl"
source="https://github.com/irssi/irssi/releases/download/$pkgver/irssi-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
# secfixes:
# 1.0.3-r0:
# - CVE-2017-9468
# - CVE-2017-9469
build() {
cd "$builddir"
./configure \
......@@ -57,4 +61,4 @@ proxy() {
mv "$pkgdir"/usr/lib/irssi/modules/libirc_proxy.* "$subpkgdir"/usr/lib/irssi/modules/
}
sha512sums="0b5048b1babecaafcd6f2be59523635a3f028c17ceb751776099d74c50fc3daf8fdf52ef5c37f9b765f7a1e5e82f5e41230d14f05530de54386f7190c610d458 irssi-1.0.2.tar.xz"
sha512sums="3a369d9bad4e2016a6a0395b35e3db1f1a6ff7ff6b8361fe5d828c29dd6f81c4b8d1bdfe0304cb05402eecddde97f6d369a5e98f215bfd177287f303d3d714eb irssi-1.0.3.tar.xz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment