Commit 165ba7ee authored by Natanael Copa's avatar Natanael Copa

main/fuse(3): fix conflict

make a fuse-common and fuse-openrc package so fuse(2) and fuse(3) no
longer conflict.
parent 0701a252
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fuse
pkgver=2.9.8
pkgrel=1
pkgrel=2
pkgdesc="A library that makes it possible to implement a filesystem in a userspace program."
url="https://github.com/libfuse/"
arch="all"
license="GPL-2.0-only LGPL-2.1-only"
depends=
depends="fuse-common"
makedepends="gettext-dev"
install=
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.gz
fix-realpath.patch
fuse.initd"
"
options="suid !check" # No test suite.
builddir="$srcdir"/$pkgname-$pkgver
......@@ -39,24 +39,7 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
rm -r "$pkgdir"/dev "$pkgdir"/etc/init.d
install -Dm755 "$srcdir"/fuse.initd "$pkgdir"/etc/init.d/fuse
# create config
install -d "$pkgdir"/etc
cat >"$pkgdir"/etc/fuse.conf << _EOF_
# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#
#mount_max = 1000
# Allow non-root users to specify the 'allow_other' or 'allow_root'
# mount options.
#
#user_allow_other
_EOF_
}
sha512sums="0a9b14d96c6f98f5c903baf00114bfff72f9aeb97224702bbed370516b2b582401d5b436fcef979918ffd85d69ba4a82c8f722c0b35ebd50f7aa5f4ddfdcf8ad fuse-2.9.8.tar.gz
5672ceb35acabb4bd97b6efc30614f22def62882fe198e2a8598a074d45b6b5337c082a5e09b5e399b6e5212dc1fbde9071c2a5051534c32091444c350b9c657 fix-realpath.patch
7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1 fuse.initd"
5672ceb35acabb4bd97b6efc30614f22def62882fe198e2a8598a074d45b6b5337c082a5e09b5e399b6e5212dc1fbde9071c2a5051534c32091444c350b9c657 fix-realpath.patch"
......@@ -7,15 +7,15 @@ pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace
url="https://github.com/libfuse/libfuse"
arch="all"
license="GPL-2.0-only LGPL-2.1-only"
depends="!fuse"
depends="fuse-common"
makedepends="gettext-dev linux-headers meson eudev-dev python3
py3-six py3-pluggy py3-attrs py3-py"
checkdepends="py3-pytest"
subpackages="$pkgname-dev $pkgname-doc"
subpackages="$pkgname-dev $pkgname-doc fuse-common:_common fuse-openrc:_openrc"
source="https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.xz
fix-realpath.patch
fuse.initd"
options="suid"
options="suid !check" # check is currently broken: https://github.com/libfuse/libfuse/issues/293
builddir="$srcdir"/$_pkgname-$pkgver
......@@ -59,7 +59,17 @@ package() {
#
#user_allow_other
_EOF_
}
_common() {
pkgdesc="Common files for fuse2 and fuse3"
mkdir -p "$subpkgdir"/etc/
mv "$pkgdir"/etc/fuse.conf "$subpkgdir"
}
_openrc() {
default_openrc
install_if="openrc fuse-common=$pkgver-r$pkgrel"
}
sha512sums="90c56a6652967450f03cb0f20ae929091a3e8b3f6927fe7a6ce59bb5e3f247d34a44ce19f085ab09547d9cc38ab1cec1e71fe44ec5c4f201782150aadcbe6b4f fuse-3.2.5.tar.xz
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment