main/varnish: upgrade to 7.0.0

A few things changed:
- pcre2 is now needed instead of pcre
- no more update_config_sub
- verbose test errors
- patch failing vtc (https://github.com/varnishcache/varnish-cache/issues/3698)
- main/varnish: verbose make check
- don't run tests on x86 (https://github.com/varnishcache/varnish-cache/issues/3697)
8 jobs for !25372 with varnish_7.0.0 in 6 minutes and 39 seconds (queued for 5 seconds)
latest merge request