From ffd76e0bae9921b604c4d3fab6e236e6c7b4039a Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Mon, 24 Apr 2023 16:26:43 +0000
Subject: [PATCH] main/lame: fix id3 tag writes

---
 main/lame/APKBUILD        |  4 +++-
 main/lame/id3tagfix.patch | 29 +++++++++++++++++++++++++++++
 2 files changed, 32 insertions(+), 1 deletion(-)
 create mode 100644 main/lame/id3tagfix.patch

diff --git a/main/lame/APKBUILD b/main/lame/APKBUILD
index 0b39f3f771dd..1be22556321c 100644
--- a/main/lame/APKBUILD
+++ b/main/lame/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=lame
 pkgver=3.100
-pkgrel=4
+pkgrel=5
 pkgdesc="An MP3 encoder and graphical frame analyzer"
 url="https://lame.sourceforge.net/"
 arch="all"
@@ -9,6 +9,7 @@ license="LGPL-2.0-or-later"
 subpackages="$pkgname-dev $pkgname-libs $pkgname-doc"
 makedepends="nasm ncurses-dev autoconf automake libtool"
 source="https://downloads.sourceforge.net/project/lame/lame/$pkgver/lame-$pkgver.tar.gz
+	id3tagfix.patch
 	lame.pc.in
 	"
 
@@ -59,5 +60,6 @@ package() {
 
 sha512sums="
 0844b9eadb4aacf8000444621451277de365041cc1d97b7f7a589da0b7a23899310afd4e4d81114b9912aa97832621d20588034715573d417b2923948c08634b  lame-3.100.tar.gz
+2b47995715c526c74e782ac34778b7075fad1fa16b5299e73b2c62cdf6bfa64ba0862d18e949565aff49c613d2468794dc6e336836ed4ebdb2e6ef67be8af5b0  id3tagfix.patch
 ace7813debdb2cd8b08c26e99db50776180b05105832db96ad0bb314dc3e1eadccfd14de3adab7b1a37b6df7d521b5216ed7d9c3c11d5bae388197debca58f0f  lame.pc.in
 "
diff --git a/main/lame/id3tagfix.patch b/main/lame/id3tagfix.patch
new file mode 100644
index 000000000000..4b633f1cbeb7
--- /dev/null
+++ b/main/lame/id3tagfix.patch
@@ -0,0 +1,29 @@
+Patch-Source: https://github.com/void-linux/void-packages/commit/ba30046be66be546c307c4186d54f448a674fb7e
+musl doesn't have translit, so just remove it
+--
+--- a/frontend/parse.c
++++ b/frontend/parse.c
+@@ -232,7 +232,11 @@
+         dst = calloc(n+4, 4);
+         if (dst != 0) {
+             char* cur_code = nl_langinfo(CODESET);
++#ifdef __GLIBC__
+             iconv_t xiconv = iconv_open("ISO_8859-1//TRANSLIT", cur_code);
++#else
++            iconv_t xiconv = iconv_open("ISO_8859-1", cur_code);
++#endif
+             if (xiconv != (iconv_t)-1) {
+                 char* i_ptr = (char*)src;
+                 char* o_ptr = dst;
+@@ -258,7 +262,11 @@
+         dst = calloc(n+4, 4);
+         if (dst != 0) {
+             char* cur_code = nl_langinfo(CODESET);
++#ifdef __GLIBC__
+             iconv_t xiconv = iconv_open("UTF-16LE//TRANSLIT", cur_code);
++#else
++            iconv_t xiconv = iconv_open("UTF-16LE", cur_code);
++#endif
+             dst[0] = 0xff;
+             dst[1] = 0xfe;
+             if (xiconv != (iconv_t)-1) {
-- 
GitLab