Commit fe9dd4f7 authored by A. Klitzing's avatar A. Klitzing

testing/libbytesize: upgrade to 2.0

parent 3962746f
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=libbytesize
pkgver=1.4
pkgrel=1
pkgver=2.0
pkgrel=0
pkgdesc="Library for working with arbitrary big sizes in bytes"
url="https://github.com/rhinstaller/libbytesize"
arch="all"
license="LGPL-2.1-or-later"
makedepends="gettext-dev gmp-dev mpfr-dev pcre-dev python3"
subpackages="$pkgname-dev $pkgname-lang py-$pkgname:py"
makedepends="gettext-dev gmp-dev mpfr-dev pcre2-dev python3"
checkdepends="py3-polib"
options="!check" # ModuleNotFoundError: No module named 'pocketlint'
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py-$pkgname:py:noarch"
source="https://github.com/storaged-project/libbytesize/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
build() {
cd "$builddir"
./configure --prefix=/usr
make
}
check() {
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
......@@ -29,4 +33,4 @@ py() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
sha512sums="54aba1f605ad662ff525c47206e8342e727c807692225361f1fa8d6a66c00f2740fc3d3672978eec2806227d85f146034042a9808e458d8d6271a08934032959 libbytesize-1.4.tar.gz"
sha512sums="9d2a18930d0d900262ced4abd5cd358896570eadb06435f1b9aba5484ca530478b65dfb4982e8acf77ca4519a2d8a1dc236d42f5fa1ecbd7461949b282ef44a1 libbytesize-2.0.tar.gz"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment