From fd47d7f25de82d9a64379ee9a8c8df13f60392c2 Mon Sep 17 00:00:00 2001
From: KikooDX <kikoodx@paranoici.org>
Date: Thu, 18 Mar 2021 10:47:41 +0000
Subject: [PATCH] testing/afetch: new aport

https://github.com/13-CF/afetch
Fast and simple system info written in C
---
 testing/afetch/APKBUILD | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 testing/afetch/APKBUILD

diff --git a/testing/afetch/APKBUILD b/testing/afetch/APKBUILD
new file mode 100644
index 000000000000..8782bf8b3543
--- /dev/null
+++ b/testing/afetch/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: KikooDX <kikoodx@paranoici.org>
+# Maintainer: KikooDX <kikoodx@paranoici.org>
+pkgname=afetch
+pkgver=0_git20210318
+pkgrel=0
+pkgdesc="Fast and simple system info written in C"
+url="https://github.com/13-CF/afetch"
+arch="all"
+license="GPL-3.0-or-later"
+subpackages="$pkgname-doc"
+options="!check" # there is no test suite
+_gitrev=4eb0e27e67782fdbebf1abd472aa0f5c1ea6c365
+source="$pkgname-$_gitrev.tar.gz::https://github.com/13-CF/afetch/archive/$_gitrev.tar.gz"
+builddir="$srcdir/$pkgname-$_gitrev"
+
+build() {
+	make
+}
+
+package() {
+	make PREFIX=/usr DESTDIR="$pkgdir" install
+	install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="91a23925bbf21ac3d312e5aecf750e3fb111c16058d7c571ac3b8be09c934d21f5af17901531adda007ebb2a3a84b5b2e5b46aa3f6fe6c8d51bdeb3636aba6c0  afetch-4eb0e27e67782fdbebf1abd472aa0f5c1ea6c365.tar.gz"
-- 
GitLab