From fb492dda5d427aff77d3cf78aa8f99b04010a6e2 Mon Sep 17 00:00:00 2001
From: Bart Ribbers <bribbers@disroot.org>
Date: Wed, 18 Mar 2020 13:18:03 +0100
Subject: [PATCH] community/telepathy-qt: add https to url

---
 community/telepathy-qt/APKBUILD | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

diff --git a/community/telepathy-qt/APKBUILD b/community/telepathy-qt/APKBUILD
index 6484180ba59d..9d87aefe9544 100644
--- a/community/telepathy-qt/APKBUILD
+++ b/community/telepathy-qt/APKBUILD
@@ -2,9 +2,9 @@
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=telepathy-qt
 pkgver=0.9.8
-pkgrel=1
+pkgrel=2
 arch="all"
-url="http://telepathy.freedesktop.org/wiki/"
+url="https://telepathy.freedesktop.org/wiki/"
 license="LGPL-2.1-or-later"
 pkgdesc="A library for Qt-based Telepathy clients"
 depends_dev="telepathy-farstream-dev telepathy-glib-dev gstreamer-dev"
@@ -14,7 +14,7 @@ subpackages="$pkgname-dev $pkgname-doc"
 options="!check"
 
 build() {
-	cmake \
+	cmake -B build \
 		-DCMAKE_BUILD_TYPE=None \
 		-DCMAKE_INSTALL_PREFIX=/usr \
 		-DCMAKE_INSTALL_LIBDIR=lib \
@@ -22,19 +22,22 @@ build() {
 		-DDESIRED_QT_VERSION=5 \
 		-DENABLE_EXAMPLES=OFF \
 		-DENABLE_TESTS=TRUE
-	make
+	make -C build
 
+	cd build
 	doxygen doxygen.cfg
 }
 
 check() {
+	cd build
+
 	# BaseConnectionManager requires jabber support
 	# BaseProtocol is broken
 	CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "Base(ConnectionManager|Protocol)"
 }
 
 package() {
-	DESTDIR="$pkgdir" make install
+	DESTDIR="$pkgdir" make -C build install
 
 	install -d "$pkgdir"/usr/share/doc/$pkgname
 	cp -r doc/html "$pkgdir"/usr/share/doc/$pkgname/
-- 
GitLab