Commit fa930350 authored by Natanael Copa's avatar Natanael Copa
Browse files

x11/webkit: upgrade to 1.1.11

and enable html5 video
parent 51b47a46
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=webkit
pkgver=1.1.10
pkgver=1.1.11
pkgrel=0
pkgdesc="portable web rendering engine WebKit for GTK+"
url="http://webkitgtk.org/"
license="LGPL BSD"
depends=
makedepends="
libsoup-dev pango-dev gtk+-dev libjpeg-dev libpng-dev libxml2-dev
libsoup-dev pango-dev gtk+-dev jpeg-dev libpng-dev libxml2-dev
gperf pkgconfig bison flex uclibc++-dev icu-dev cairo-dev atk-dev
gnutls-dev sqlite-dev libxslt-dev libxt-dev libiconv-dev gettext-dev
zlib-dev libgcrypt-dev libgpg-error-dev expat-dev e2fsprogs-dev
enchant-dev libxi-dev libxrandr-dev libxcursor-dev libxdamage-dev
libxcomposite-dev
libxcomposite-dev gstreamer-dev gst-plugins-base-dev
"
install=
subpackages="$pkgname-dev gtklauncher"
source="http://webkitgtk.org/$pkgname-$pkgver.tar.gz"
depends_dev="gtk+-dev libsoup-dev"
depends_dev="gtk+-dev libsoup-dev gstreamer-dev"
build() {
cd "$srcdir"/$pkgname-$pkgver
......@@ -26,8 +26,7 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--disable-video
--infodir=/usr/share/info
make || return 1
make DESTDIR="$pkgdir" install
}
......@@ -40,4 +39,4 @@ gtklauncher() {
"$subpkgdir"/usr/bin/GtkLauncher
}
md5sums="b852753b3e21f010f565312132f88311 webkit-1.1.10.tar.gz"
md5sums="022a72ba5b7fa9e29553c03bf027215f webkit-1.1.11.tar.gz"
This diff is collapsed.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment