diff --git a/testing/horust/APKBUILD b/testing/horust/APKBUILD
index 8967ce6b5fd6eed2614eead5fc0d81a424044880..0655f4834ac482375a506222c90c5d3444e01a1a 100644
--- a/testing/horust/APKBUILD
+++ b/testing/horust/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: William Desportes <williamdes@wdes.fr>
 pkgname=horust
 pkgver=0.1.7
-pkgrel=1
+pkgrel=2
 pkgdesc="Horust is a supervisor / init system written in rust and designed to be run inside containers"
 url="https://github.com/FedericoPonzi/Horust"
 # s390x, riscv64: nix/libc crates lack support
@@ -14,6 +14,7 @@ checkdepends="bash" # test_single_command uses bash
 subpackages="$pkgname-doc"
 options="net"
 source="$pkgname-$pkgver.tar.gz::https://github.com/FedericoPonzi/Horust/archive/v$pkgver.tar.gz
+	bump-getrandom.patch
 	"
 builddir="$srcdir/Horust-$pkgver"
 
@@ -42,4 +43,5 @@ package() {
 
 sha512sums="
 caa762f9ccc14ed058732f023e0e347fbf5968d500dea3e3f30c9ba91b4f93aeaaefd4e41e434fca320b8b1416550c9f83383d7406015a3e60de8f71d85418c3  horust-0.1.7.tar.gz
+194dd127fb16458cd2cb424ac41f1cff5cab16901b495acad56dc6f365fe4990141f7218dd9dd121a66aa1735cb386a133f0b03b732b062a7bf9b70c22a13067  bump-getrandom.patch
 "
diff --git a/testing/horust/bump-getrandom.patch b/testing/horust/bump-getrandom.patch
new file mode 100644
index 0000000000000000000000000000000000000000..5fa4c9f3c6ed4ed2fe8a4d5e647b795207675075
--- /dev/null
+++ b/testing/horust/bump-getrandom.patch
@@ -0,0 +1,28 @@
+Bump to the first version that doesn't use open64
+
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -413,9 +413,9 @@
+ 
+ [[package]]
+ name = "getrandom"
+-version = "0.2.3"
++version = "0.2.9"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "7fcd999463524c52659517fe2cea98493cfe485d10565e7b0fb07dbba7ad2753"
++checksum = "c85e1d9ab2eadba7e5040d4e09cbd6d072b76a557ad64e797c2cb9d4da21d7e4"
+ dependencies = [
+  "cfg-if",
+  "libc",
+@@ -1386,9 +1386,9 @@
+ 
+ [[package]]
+ name = "wasi"
+-version = "0.10.2+wasi-snapshot-preview1"
++version = "0.11.0+wasi-snapshot-preview1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "fd6fbd9a79829dd1ad0cc20627bf1ed606756a7f77edff7b66b7064f9cb327c6"
++checksum = "9c8d87e72b64a3b4db28d11ce29237c246188f4f51057d65a7eab63b7987e423"
+ 
+ [[package]]
+ name = "wasm-bindgen"