From f910b467171b9a907abd0a804584a7077223b78c Mon Sep 17 00:00:00 2001
From: J0WI <J0WI@users.noreply.github.com>
Date: Tue, 8 Jun 2021 00:17:17 +0200
Subject: [PATCH] main/iperf3: upgrade to 3.10.1

---
 main/iperf3/APKBUILD                          | 12 +--
 ...4-bit-time_t-works-on-32-bit-systems.patch | 73 -------------------
 2 files changed, 6 insertions(+), 79 deletions(-)
 delete mode 100644 main/iperf3/Ensure-64-bit-time_t-works-on-32-bit-systems.patch

diff --git a/main/iperf3/APKBUILD b/main/iperf3/APKBUILD
index d59d415d9168..c20a3f243c04 100644
--- a/main/iperf3/APKBUILD
+++ b/main/iperf3/APKBUILD
@@ -2,8 +2,8 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=iperf3
 _pkgname=iperf
-pkgver=3.9
-pkgrel=1
+pkgver=3.10.1
+pkgrel=0
 pkgdesc="A tool to measure IP bandwidth using UDP or TCP"
 url="https://github.com/esnet/iperf"
 arch="all"
@@ -15,7 +15,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/esnet/$_pkgname/archive/$pkg
 
 	build-fixes.patch
 	remove-pg-flags.patch
-	Ensure-64-bit-time_t-works-on-32-bit-systems.patch
 	"
 builddir="$srcdir/$_pkgname-$pkgver"
 
@@ -34,7 +33,7 @@ build() {
 		--mandir=/usr/share/man \
 		--infodir=/usr/share/info \
 		--disable-static
-	make -j1
+	make
 }
 
 check() {
@@ -50,9 +49,10 @@ package() {
 		"$pkgdir"/etc/conf.d/$pkgname
 }
 
-sha512sums="3da0939bed576a7c14baa03c996e6f407f20bfe58c4b3a36a66e74f41bd5442c0b23ab18c8eb1f2f37fd47449af533b61b658d810c68707b2b06d28894ac2035  iperf3-3.9.tar.gz
+sha512sums="
+d1139aed0c7a99e8cfc23c41d606854d48a57db24d45ea31412d81222b09faeee6edccdf4030a00eeb6acbfd540d4b985b4a89f81a4d5b84592339ad5e2e9e41  iperf3-3.10.1.tar.gz
 fdaf06316886ae02a865848ea6df6b77aecde78fab15bcbc22e077871c3f567521eeee19ef13c402fef467c2edd916a7d976a4c933dbfb637373145a18563ef9  iperf3.initd
 4c6b766c154612f5f2e5f6150396f443ba37ec59ed0a8a994bf84612059db22827aee3dd3b7c3249e0bb6037163788d830efcb1caad5eba1c97d2349bdbc55f9  iperf3.confd
 aef39e45bf63341b724b9131d8bfdf96702acc059e10d7d502053effa69a03097f64e9ba2a26c6a1e3e1567cf9a95013fc58b3b47623de79add14230bd820fa0  build-fixes.patch
 9334d51ec4bb4931272f972a83109dadd44123c9b46803a5b2d16e725576b860f93b62ae3d85be2a2d8a955cff24211da7675fe733a4f3ad8aaae005939a4097  remove-pg-flags.patch
-587a66e1a91ba260deb7c0f574b9016f0a2d61765776efc5bd5c4dec263b3acbb27109cbd9e2a9962d72e726fbc02638cf279bd2e3cf2c42b43c1919ba03b2a1  Ensure-64-bit-time_t-works-on-32-bit-systems.patch"
+"
diff --git a/main/iperf3/Ensure-64-bit-time_t-works-on-32-bit-systems.patch b/main/iperf3/Ensure-64-bit-time_t-works-on-32-bit-systems.patch
deleted file mode 100644
index 60b949bbcfe4..000000000000
--- a/main/iperf3/Ensure-64-bit-time_t-works-on-32-bit-systems.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 2a1309faf80f07bda1ba020ce8cfa09529561e57 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Wed, 30 Sep 2020 12:29:33 -0500
-Subject: [PATCH] fix[auth]: Ensure 64-bit time_t works on 32-bit systems
- (#1056)
-
-On a 32-bit PowerPC Linux system using musl libc (with 64-bit time_t),
-the t_auth test fails because `long` is not the same type as `time_t`.
-
-This patch uses an int64_t temporary value, which can be truncated to
-32-bit if necessary.
----
- src/iperf_auth.c | 12 ++++++++----
- 1 file changed, 8 insertions(+), 4 deletions(-)
-
-diff --git a/src/iperf_auth.c b/src/iperf_auth.c
-index eb4610f2..a824deba 100644
---- a/src/iperf_auth.c
-+++ b/src/iperf_auth.c
-@@ -35,6 +35,8 @@
- #define _WITH_GETLINE
- #include <stdio.h>
- #include <termios.h>
-+#include <inttypes.h>
-+#include <stdint.h>
- 
- #if defined(HAVE_SSL)
- 
-@@ -45,7 +47,7 @@
- #include <openssl/buffer.h>
- #include <openssl/err.h>
- 
--const char *auth_text_format = "user: %s\npwd:  %s\nts:   %ld";
-+const char *auth_text_format = "user: %s\npwd:  %s\nts:   %"PRId64;
- 
- void sha256(const char *string, char outputBuffer[65])
- {
-@@ -291,7 +293,7 @@ int encode_auth_setting(const char *username, const char *password, EVP_PKEY *pu
-     if (text == NULL) {
- 	return -1;
-     }
--    snprintf(text, text_len, auth_text_format, username, password, utc_seconds);
-+    snprintf(text, text_len, auth_text_format, username, password, (int64_t)utc_seconds);
- 
-     unsigned char *encrypted = NULL;
-     int encrypted_len;
-@@ -309,7 +311,8 @@ int encode_auth_setting(const char *username, const char *password, EVP_PKEY *pu
- int decode_auth_setting(int enable_debug, const char *authtoken, EVP_PKEY *private_key, char **username, char **password, time_t *ts){
-     unsigned char *encrypted_b64 = NULL;
-     size_t encrypted_len_b64;
--    Base64Decode(authtoken, &encrypted_b64, &encrypted_len_b64);        
-+    int64_t utc_seconds;
-+    Base64Decode(authtoken, &encrypted_b64, &encrypted_len_b64);
- 
-     unsigned char *plaintext = NULL;
-     int plaintext_len;
-@@ -331,7 +334,7 @@ int decode_auth_setting(int enable_debug, const char *authtoken, EVP_PKEY *priva
- 	return -1;
-     }
- 
--    int rc = sscanf((char *) plaintext, auth_text_format, s_username, s_password, ts);
-+    int rc = sscanf((char *) plaintext, auth_text_format, s_username, s_password, &utc_seconds);
-     if (rc != 3) {
- 	free(s_password);
- 	free(s_username);
-@@ -344,6 +347,7 @@ int decode_auth_setting(int enable_debug, const char *authtoken, EVP_PKEY *priva
-     }
-     *username = s_username;
-     *password = s_password;
-+    *ts = (time_t)utc_seconds;
-     OPENSSL_free(plaintext);
-     return (0);
- }
-- 
GitLab