Commit f8f4b275 authored by Natanael Copa's avatar Natanael Copa
Browse files

main/nodejs: build with shared c-ares

parent 7f9206ba
......@@ -8,7 +8,7 @@ pkgname=nodejs
# Note: Update only to even-numbered versions (e.g. 6.y.z, 8.y.z)!
# Odd-numbered versions are supported only for 9 months by upstream.
pkgver=6.11.1
pkgrel=0
pkgrel=1
pkgdesc="JavaScript runtime built on V8 engine - LTS version"
url="http://nodejs.org/"
arch="all"
......@@ -17,7 +17,7 @@ depends="ca-certificates"
depends_dev="libuv"
# gold is needed for mksnapshot
makedepends="$depends_dev python2 openssl-dev zlib-dev libuv-dev linux-headers
paxmark binutils-gold http-parser-dev ca-certificates"
paxmark binutils-gold http-parser-dev ca-certificates c-ares-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-npm::noarch"
provides="nodejs-lts=$pkgver" # for backward compatibility
replaces="nodejs-current nodejs-lts" # nodejs-lts for backward compatibility
......@@ -41,6 +41,7 @@ build() {
--shared-libuv \
--shared-openssl \
--shared-http-parser \
--shared-cares \
--openssl-use-def-ca-store \
|| return 1
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment