diff --git a/testing/bandwhich/APKBUILD b/testing/bandwhich/APKBUILD
index 1e59d696512927759bf1a902415305ac20c8d6c5..fae81d0ff3d6963514fbf2c3e4324363b57cc3fd 100644
--- a/testing/bandwhich/APKBUILD
+++ b/testing/bandwhich/APKBUILD
@@ -1,11 +1,11 @@
 # Contributor: Anjandev Momi <anjan@momi.ca>
 # Maintainer: Anjandev Momi <anjan@momi.ca>
 pkgname=bandwhich
-pkgver=0.16.0
-pkgrel=1
+pkgver=0.20.0
+pkgrel=0
 pkgdesc="Terminal bandwidth utilization tool"
 url="https://github.com/imsnif/bandwhich"
-arch="all !s390x !mips !mips64" # Limited by cargo
+arch="all !s390x !mips !mips64" # limited by cargo
 license="MIT"
 makedepends="cargo"
 source="$pkgname-$pkgver.tar.gz::https://github.com/imsnif/bandwhich/archive/$pkgver.tar.gz"
@@ -22,4 +22,4 @@ package() {
 	install -Dm755 target/release/bandwhich "$pkgdir"/usr/bin/bandwhich
 }
 
-sha512sums="c8708ebce6799cb4017e2dae40735d83b2dc51736048c1f7cdf5a59197434a30f7a5a3ccb3bb323892cada24de88099660a42c0a0f2cd7c477bf5a7d5b1ac158  bandwhich-0.16.0.tar.gz"
+sha512sums="3bd5cc4166514feb601eb921ef3fbad08b8e9787aad1bb0c8a9543207631964ffc14cc1488e96ef4319bb1a20c5f684b744facd2a6cf1d9ef6dd5d2fefc524cb  bandwhich-0.20.0.tar.gz"