diff --git a/community/convfmt/APKBUILD b/community/convfmt/APKBUILD
index 34cfb4d7bad59e1b86ccf5f8027a031b2d417eda..3f9f242deee535186d246853e4b0c063afd8c512 100644
--- a/community/convfmt/APKBUILD
+++ b/community/convfmt/APKBUILD
@@ -1,17 +1,14 @@
 # Contributor: Jakub Jirutka <jakub@jirutka.cz>
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=convfmt
-pkgver=0.1.6
-pkgrel=1
+pkgver=0.1.7
+pkgrel=0
 pkgdesc="CLI tool which can convert between JSON, YAML, TOML etc."
 url="https://github.com/oriontvv/convfmt"
-# loongarch64: blocked by libc crate
-arch="all !loongarch64"
+arch="all"
 license="Apache-2.0"
 makedepends="cargo cargo-auditable"
-source="https://github.com/oriontvv/convfmt/archive/$pkgver/convfmt-$pkgver.tar.gz
-	bump-unsafe-libyaml.patch
-	"
+source="https://github.com/oriontvv/convfmt/archive/$pkgver/convfmt-$pkgver.tar.gz"
 
 prepare() {
 	default_prepare
@@ -32,6 +29,5 @@ package() {
 }
 
 sha512sums="
-66edf458f2114b4cee3cece116a236ff94e5c52345073673f042e33c5b710b583e0b4d0b0a2399d2c4031e0b9ad825eecba6d15c1d908a231d42f44ac86cd47e  convfmt-0.1.6.tar.gz
-c91e04576ad33709ed6c3b5a9da7707d2a9832fe5fde3dc8f20ff32888f78c7ae8ba99f3016e0c363c3b86f737da2615f6f6cb919f0f10776716f4b3f2ce6f79  bump-unsafe-libyaml.patch
+ee7cd06477338ed1abe745ece59731169992feeb8d4e5342abdd8d2285eb76f78441a28b16ea630bf95ce7534732b27916cfb6f8f0547cd8becbca7358cfd7b7  convfmt-0.1.7.tar.gz
 "
diff --git a/community/convfmt/bump-unsafe-libyaml.patch b/community/convfmt/bump-unsafe-libyaml.patch
deleted file mode 100644
index 97216329ac757d940a822dc90a22f9f9e0b6e269..0000000000000000000000000000000000000000
--- a/community/convfmt/bump-unsafe-libyaml.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-thread 'tests::test_convert_formats::case_01' panicked at core/src/panicking.rs:221:5:
-unsafe precondition(s) violated: ptr::copy_nonoverlapping requires that both pointer arguments are aligned and non-null and the specified memory ranges do not overlap
-
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -774,9 +774,9 @@
- 
- [[package]]
- name = "unsafe-libyaml"
--version = "0.2.8"
-+version = "0.2.11"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "1865806a559042e51ab5414598446a5871b561d21b6764f2eabb0dd481d880a6"
-+checksum = "673aac59facbab8a9007c7f6108d11f63b603f7cabff99fabf650fea5c32b861"
- 
- [[package]]
- name = "utf8parse"