diff --git a/testing/grommunio-web/0001-makefile.patch b/testing/grommunio-web/0001-makefile.patch
index 871e9d62981a17b1da1b463def89843d10781650..60309aa8799835eaaa7c3fe8179fffe05fb43f69 100644
--- a/testing/grommunio-web/0001-makefile.patch
+++ b/testing/grommunio-web/0001-makefile.patch
@@ -1,3 +1,5 @@
+# musl cp -rn behaves differently from gnu cp -rn
+# the gnu version verifies on file level whether the target exists and musl on directory level only
 diff -ruN a/Makefile b/Makefile
 --- a/Makefile	2024-03-06 10:42:16.333816043 +0100
 +++ b/Makefile	2024-03-06 10:42:34.613808357 +0100
diff --git a/testing/grommunio-web/APKBUILD b/testing/grommunio-web/APKBUILD
index cd01032b5017bbccd8ff7e76e8318325f6f0e265..07659565c21548285a41bc0a9381ffa3470cf298 100644
--- a/testing/grommunio-web/APKBUILD
+++ b/testing/grommunio-web/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Noel Kuntze <noel.kuntze@contauro.com>
 pkgname=grommunio-web
 pkgver=3.8
-pkgrel=1
+pkgrel=2
 pkgdesc="Web user interface for grommunio"
 # s390x: blocked by grommunio-gromox
 arch="noarch !riscv64 !s390x"
@@ -13,7 +13,6 @@ install="$pkgname.pre-install $pkgname.pre-upgrade"
 depends="grommunio-gromox
 	grommunio-mapi-header-php
 	$_php
-	$_php-gettext
 	$_php-bcmath
 	$_php-ctype
 	$_php-curl
@@ -23,6 +22,8 @@ depends="grommunio-gromox
 	$_php-iconv
 	$_php-mbstring
 	$_php-openssl
+	$_php-session
+	$_php-simplexml
 	$_php-sodium
 	$_php-sqlite3
 	$_php-sysvshm
@@ -53,11 +54,13 @@ package() {
 	install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
 
 	# nginx conf
+	sed -i "s@/usr/share/grommunio-web/@/usr/share/webapps/grommunio-web/@" build/grommunio-web.conf
 	install -Dpm644 build/grommunio-web.conf "$pkgdir"/usr/share/grommunio-common/nginx/locations.d/grommunio-web.conf
+	sed -i "s@/php-fpm/@/php-fpm${_php#php}/@" build/grommunio-web-upstream.conf
 	install -Dpm644 build/grommunio-web-upstream.conf "$pkgdir"/usr/share/grommunio-common/nginx/upstreams.d/grommunio-web.conf
 
 	# php-fpm
-	sed -i "s@/php-fpm/@/php-fpm${_php##php}/@" build/pool-grommunio-web.conf
+	sed -i "s@/php-fpm/@/php-fpm${_php#php}/@" build/pool-grommunio-web.conf
 	install -Dpm644 build/pool-grommunio-web.conf "$pkgdir"/etc/$_php/php-fpm.d/pool-grommunio-web.conf
 
 	# web config
@@ -82,9 +85,12 @@ package() {
 		/var/lib/grommunio-web/tmp; do
 		install -dm 0770 -g groweb -o groweb "$pkgdir"/$i
 	done
+
+	# store version
+	echo $pkgver-$pkgrel > "$pkgdir"/usr/share/webapps/grommunio-web/version
 }
 
 sha512sums="
 f7223aac98e77cbfcd504a611507590b7a5389f00b5f89db743b3f1101ff3cd8504116ffa30889821dd7cb0fe329722ab5ba13c9155e2bfce7792868967b86c2  grommunio-web-3.8.tar.gz
-fcfb070ab0bb8cca6f24221fe66eeac7e0c33981c16fff947db7509cc73d39b086710e5fd75bce34a230fa18bc10828d87410d98d147d31cc6ae1c16c41b48ae  0001-makefile.patch
+6a9688216d93ccdc48d80489cd4b36a1cba5e0d57d0e8996408b0b04873804f94bef1bc8c2f4c422faa8383589b5f4d30fec5755b0cd3e23739edbeaa1feae54  0001-makefile.patch
 "
diff --git a/testing/grommunio-web/grommunio-web.pre-install b/testing/grommunio-web/grommunio-web.pre-install
index d0248c9c13618740ab09cf5aeccc41f206944dd9..10151ced9d405efd3a66a60b79aa4756097b5c03 100644
--- a/testing/grommunio-web/grommunio-web.pre-install
+++ b/testing/grommunio-web/grommunio-web.pre-install
@@ -1,7 +1,7 @@
 #!/bin/sh
 
 addgroup -S groweb 2>/dev/null
-adduser -S -D -H -h /usr/share/grommunio-web -s /sbin/nologin -G groweb -g "Grommunio web" groweb 2>/dev/null
+adduser -S -D -H -h /usr/share/webapps/grommunio-web -s /sbin/nologin -G groweb -g "Grommunio web" groweb 2>/dev/null
 addgroup grommunio groweb 2>/dev/null
 
 exit 0