From f6a1a2ea2c8b8ab577205174f3ab777a024d562a Mon Sep 17 00:00:00 2001
From: Bart Ribbers <bribbers@disroot.org>
Date: Thu, 2 Feb 2023 15:19:22 +0000
Subject: [PATCH] community/supertuxkart: upgrade to 1.4

---
 community/supertuxkart/64bittype.patch       | 31 ++++++++++++++++++++
 community/supertuxkart/APKBUILD              | 15 +++++-----
 community/supertuxkart/no-install-libs.patch | 23 +++++++++++++++
 3 files changed, 62 insertions(+), 7 deletions(-)
 create mode 100644 community/supertuxkart/64bittype.patch
 create mode 100644 community/supertuxkart/no-install-libs.patch

diff --git a/community/supertuxkart/64bittype.patch b/community/supertuxkart/64bittype.patch
new file mode 100644
index 000000000000..b289012aae3c
--- /dev/null
+++ b/community/supertuxkart/64bittype.patch
@@ -0,0 +1,31 @@
+these definitions conflict with directfb which also typedefs `u64` `s64`
+diff --git a/lib/irrlicht/include/irrTypes.h b/lib/irrlicht/include/irrTypes.h
+index be79677..a63c7a4 100644
+--- a/lib/irrlicht/include/irrTypes.h
++++ b/lib/irrlicht/include/irrTypes.h
+@@ -5,6 +5,7 @@
+ #ifndef __IRR_TYPES_H_INCLUDED__
+ #define __IRR_TYPES_H_INCLUDED__
+ 
++#include <stdint.h>
+ #include "IrrCompileConfig.h"
+ 
+ namespace irr
+@@ -76,7 +77,7 @@ typedef unsigned __int64			u64;
+ #if __WORDSIZE == 64
+ typedef unsigned long int 			u64;
+ #else
+-__extension__ typedef unsigned long long	u64;
++typedef uint64_t u64;
+ #endif
+ #else
+ typedef unsigned long long			u64;
+@@ -90,7 +91,7 @@ typedef __int64					s64;
+ #if __WORDSIZE == 64
+ typedef long int 				s64;
+ #else
+-__extension__ typedef long long			s64;
++typedef int64_t s64;
+ #endif
+ #else
+ typedef long long				s64;
diff --git a/community/supertuxkart/APKBUILD b/community/supertuxkart/APKBUILD
index 413c9e482eb4..d26ab769fc97 100644
--- a/community/supertuxkart/APKBUILD
+++ b/community/supertuxkart/APKBUILD
@@ -2,8 +2,8 @@
 # Contributor: Antoni Aloy <aaloytorrens@gmail.com>
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=supertuxkart
-pkgver=1.3
-pkgrel=4
+pkgver=1.4
+pkgrel=0
 # s390x mainframes don't have GPUs
 arch="all !s390x"
 url="https://supertuxkart.net/"
@@ -32,8 +32,10 @@ makedepends="
 	"
 source="https://github.com/supertuxkart/stk-code/releases/download/$pkgver/SuperTuxKart-$pkgver-src.tar.xz
 	server_config.xml
+	64bittype.patch
+	no-install-libs.patch
 	"
-subpackages="$pkgname-server $pkgname-static $pkgname-data::noarch"
+subpackages="$pkgname-server $pkgname-data::noarch"
 builddir="$srcdir/SuperTuxKart-$pkgver-src"
 
 [ "$CARCH" = "riscv64" ] && options="textrels" # Temporarily allow textrels
@@ -70,9 +72,6 @@ check() {
 
 package() {
 	DESTDIR="$pkgdir" cmake --install build
-
-	# Not sure why this is in here
-	rm "$pkgdir"/usr/include/wiiuse.h
 }
 
 server() {
@@ -97,6 +96,8 @@ data() {
 }
 
 sha512sums="
-42664390c844ebca0be9b2f2aeb3c9197c0c79a7c604707b32e81ef41aec10fa36f5950f06e1540ea6f75f6c7f8a8f7f80aeda48de3d101d991420f5b20530ed  SuperTuxKart-1.3-src.tar.xz
+e88f3fb5ccdb38d0ef75e92d73b43c5cc7a1f6c76ac9502033df099a00d6dc3e86b2c5442b806237d2420c44ada7dd23a2c90ecf94785a44d2348c933770a5ab  SuperTuxKart-1.4-src.tar.xz
 104a0b6e6c7abca53b76895d8889edde7745e420e1579c46c63fbfba87c12080f248a1871a92e268f0010ec05ea3d7756072da49784a66156403050f6ec0056e  server_config.xml
+75ae2a2a5ab0992cc870fba18f262838f9c2ca04a5a03f2439f77ff352eac43c4fc1338444a53cad40f63341f8eb7543770550f8a17338c1b57f4678a5eb8386  64bittype.patch
+7ab08b69a030c8adff17a7bea12509c1119672e65fe645c16b60e91cbdf1f6ab20083c192f4db5290400ba9076b686859b8a7d2ec411552bd7bce1351019f184  no-install-libs.patch
 "
diff --git a/community/supertuxkart/no-install-libs.patch b/community/supertuxkart/no-install-libs.patch
new file mode 100644
index 000000000000..3f4d05a650ba
--- /dev/null
+++ b/community/supertuxkart/no-install-libs.patch
@@ -0,0 +1,23 @@
+this is required to not install the development files of vendored libraries
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 98dd5dc..3ed3b7b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -377,7 +377,7 @@ if(USE_WIIUSE)
+     else()
+         # Fallback to built-in version
+         if(WIIUSE_BUILD)
+-            add_subdirectory("${PROJECT_SOURCE_DIR}/lib/wiiuse")
++            add_subdirectory("${PROJECT_SOURCE_DIR}/lib/wiiuse" EXCLUDE_FROM_ALL)
+         endif()
+         include_directories(BEFORE "${PROJECT_SOURCE_DIR}/lib/wiiuse/src/include")
+         set(WIIUSE_LIBRARIES "wiiuse" "bluetooth")
+@@ -411,7 +411,7 @@ if(USE_SYSTEM_ANGELSCRIPT)
+             "-DUSE_SYSTEM_ANGELSCRIPT=0")
+     endif()
+ else()
+-    add_subdirectory("${PROJECT_SOURCE_DIR}/lib/angelscript/projects/cmake")
++    add_subdirectory("${PROJECT_SOURCE_DIR}/lib/angelscript/projects/cmake" EXCLUDE_FROM_ALL)
+     include_directories(BEFORE "${PROJECT_SOURCE_DIR}/lib/angelscript/include")
+     set(Angelscript_LIBRARIES angelscript)
+ endif()
-- 
GitLab