diff --git a/community/gnome-session/APKBUILD b/community/gnome-session/APKBUILD
index f8a6b08476b9313cdfabedc2d9c526b3c0803233..61c6535516fe3290f8f7377136bec78d1d978963 100644
--- a/community/gnome-session/APKBUILD
+++ b/community/gnome-session/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: team/gnome <ablocorrea@hotmail.com>
 pkgname=gnome-session
 pkgver=45.0
-pkgrel=0
+pkgrel=1
 pkgdesc="GNOME session manager"
 url="https://gitlab.gnome.org/GNOME/gnome-session"
 arch="all"
@@ -31,7 +31,9 @@ makedepends="
 replaces="gnome-shell"
 options="!check" #no tests
 subpackages="$pkgname-lang $pkgname-doc"
-source="https://download.gnome.org/sources/gnome-session/${pkgver%%.*}/gnome-session-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/gnome-session/${pkgver%%.*}/gnome-session-$pkgver.tar.xz
+	gnome-session-bash-login.patch
+"
 
 build() {
 	abuild-meson \
diff --git a/community/gnome-session/gnome-session-bash-login.patch b/community/gnome-session/gnome-session-bash-login.patch
new file mode 100644
index 0000000000000000000000000000000000000000..df2149f020d44ce1e7bd1c8d4c2d24404e24faae
--- /dev/null
+++ b/community/gnome-session/gnome-session-bash-login.patch
@@ -0,0 +1,17 @@
+diff --git i/gnome-session/gnome-session.in w/gnome-session/gnome-session.in
+index ddd1a591..b6dd6cb8 100755
+--- i/gnome-session/gnome-session.in
++++ w/gnome-session/gnome-session.in
+@@ -7,7 +7,11 @@ if [ "x$XDG_SESSION_TYPE" = "xwayland" ] &&
+    ! (echo "$SHELL" | grep -q "false") &&
+    ! (echo "$SHELL" | grep -q "nologin"); then
+   if [ "$1" != '-l' ]; then
+-    exec bash -c "exec -l '$SHELL' -c '$0 -l $*'"
++    if [ "x$SHELL" = "x/bin/bash" ]; then
++      exec bash -c "exec '$SHELL' -l -c '$0 -l $*'"
++    else
++      exec bash -c "exec -l '$SHELL' -c '$0 -l $*'"
++    fi
+   else
+     shift
+   fi