diff --git a/community/gitlab-runner/APKBUILD b/community/gitlab-runner/APKBUILD
index 2fdde674fbf9053f2a4d250c157c5efe0bf7fb9d..e87f6474148cf4ce4a0d7d30c2b3109765b23048 100644
--- a/community/gitlab-runner/APKBUILD
+++ b/community/gitlab-runner/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=gitlab-runner
 pkgver=15.3.0
-pkgrel=0
+pkgrel=1
 # first 8 chars of the git hash of the release, see
 # https://gitlab.com/gitlab-org/gitlab-runner/-/tags
 # PLEASE update this, since they're used to determine what version of
@@ -65,6 +65,6 @@ helper() {
 
 sha512sums="
 8eabe9a4fd04e46d4bf306dc202664e29f5cb12cba5d73820888957d694711702e026f79a84e1d5f5237cb3d1e7efed8e035129814dcc6354e708ee98e98cbe9  gitlab-runner-v15.3.0.tar.gz
-d58f883ef5c55585b8928885e06e6da44cd9f93c6d171c6b4ab22c10b277322823e5aaff210e50c7f25b30d10ce850d9a3a3b80bddcdf3df325c1b552333d375  gitlab-runner.initd
-243ed9d7575e925794213973232f95f02d5e10cfab6cd29df6a4641b9d05b342ae90678b2eea4b21ddc703596429919d037b38248046d7c5e7a480406f412445  gitlab-runner.confd
+1823f48a7432778a896309c359361a4dd15f09f6e3c820245b38198ec1d50816bb10e4a4b25a7cca918b3a7dbaff6eb570bcdb0f4fa12e2717559649510e2a6e  gitlab-runner.initd
+6f1f2d4309bedd60dcc232601760b7b7c711a758ecfa80efdbe3ed5a149781772aced6f527beaa82cbe8904f02c3095118309abd8b62dfd12a87cce7b94ee889  gitlab-runner.confd
 "
diff --git a/community/gitlab-runner/gitlab-runner.confd b/community/gitlab-runner/gitlab-runner.confd
index 98c3f285de245116c7b541850e0ef48d660b634c..1b5620df2d88edc151b36444aa90d1854eae5512 100644
--- a/community/gitlab-runner/gitlab-runner.confd
+++ b/community/gitlab-runner/gitlab-runner.confd
@@ -5,3 +5,6 @@ GITLAB_RUNNER_OPTS="--config /etc/gitlab-runner/config.toml --working-directory
 GITLAB_RUNNER_USER="gitlab-runner"
 # Same as above
 GITLAB_RUNNER_GROUP="gitlab-runner"
+
+# Comment out to run without process supervisor.
+supervisor=supervise-daemon
diff --git a/community/gitlab-runner/gitlab-runner.initd b/community/gitlab-runner/gitlab-runner.initd
index bf9502585b768d0ccc8d1507367615437916a9c0..b685ff247fd0c4c0263b73dbd0e614add8972605 100644
--- a/community/gitlab-runner/gitlab-runner.initd
+++ b/community/gitlab-runner/gitlab-runner.initd
@@ -1,13 +1,13 @@
 #!/sbin/openrc-run
 
-supervisor=supervise-daemon
-
 description="GitLab CI Runner"
 name="Gitlab Runner"
 
 command="/usr/bin/gitlab-runner"
 command_args="run ${GITLAB_RUNNER_OPTS}"
+command_background="yes"
 command_user="${GITLAB_RUNNER_USER}:${GITLAB_RUNNER_GROUP}"
+pidfile="/run/$RC_SVCNAME.pid"
 
 error_log="/var/log/gitlab-runner.log"