diff --git a/community/py3-w3lib/APKBUILD b/community/py3-w3lib/APKBUILD
index 4e997c30f5b7f39301ce203e212a9c6d8ec66f22..2c541c1d998fb4a3e0b11313d9c669ff907ee46d 100644
--- a/community/py3-w3lib/APKBUILD
+++ b/community/py3-w3lib/APKBUILD
@@ -2,7 +2,9 @@
 # Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
 pkgname=py3-w3lib
 _pkgname=w3lib
-pkgver=2.2.0
+pkgver=2.2.1
+# Upstream doesn't always tag releases
+_gittag=a50090f18c081e3eede7a070585650f835440565
 pkgrel=0
 pkgdesc="A library of web-related functions"
 url="https://github.com/scrapy/w3lib"
@@ -12,8 +14,8 @@ depends="python3"
 makedepends="py3-setuptools py3-gpep517 py3-wheel"
 checkdepends="py3-pytest"
 subpackages="$pkgname-pyc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/scrapy/w3lib/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+source="$pkgname-$_gittag.tar.gz::https://github.com/scrapy/w3lib/archive/$_gittag.tar.gz"
+builddir="$srcdir/$_pkgname-$_gittag"
 
 replaces="py-w3lib" # Backwards compatibility
 provides="py-w3lib=$pkgver-r$pkgrel" # Backwards compatibility
@@ -36,5 +38,5 @@ package() {
 }
 
 sha512sums="
-fd1d5623e02c8e13d76299a707c3ac071577c973a785dd1e9174cdf753bc0c7d467614e2252f707f38b022140451c6f5dea19de22476c297a9f06286c43bb227  py3-w3lib-2.2.0.tar.gz
+d777475d1e10806ee2397023262f2ec3b6dff566c48f85e5c18e68fe2c9b7dfc995afd54c89de6b61af67343f4b5a0c533191c716decbb7a9bbee05ed4bd0653  py3-w3lib-a50090f18c081e3eede7a070585650f835440565.tar.gz
 "