diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 8ff16c50219e33c3bdf091fb16113c7f32ad7b3c..179dba60ce939c1c10955c042d7a9d79149ec912 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -9,7 +9,7 @@ pkgver=12.1.1_git20220630
 [ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
 
 pkgname="$pkgname$_target"
-pkgrel=5
+pkgrel=6
 pkgdesc="The GNU Compiler Collection"
 url="https://gcc.gnu.org"
 arch="all"
@@ -144,7 +144,7 @@ esac
 
 _languages=c
 if $LANG_CXX; then
-	subpackages="$subpackages libstdc++:libcxx:$CTARGET_ARCH libstdc++-dev:libcxx_dev:$CTARGET_ARCH g++$_target:gpp"
+	subpackages="$subpackages libstdc++:libcxx:$CTARGET_ARCH libstdc++-dev$_target:libcxx_dev g++$_target:gpp"
 	_languages="$_languages,c++"
 fi
 if $LANG_D; then
@@ -537,16 +537,16 @@ libcxx_dev() {
 	depends=
 	replaces="g++"
 
-	amove usr/lib/libstdc++.a \
-		usr/lib/libstdc++.so \
-		usr/lib/libstdc++fs.a \
-		usr/lib/libsupc++.a \
-		usr/include/c++
+	amove usr/${_target:+$CTARGET/}lib/libstdc++.a \
+		usr/${_target:+$CTARGET/}lib/libstdc++.so \
+		usr/${_target:+$CTARGET/}lib/libstdc++fs.a \
+		usr/${_target:+$CTARGET/}lib/libsupc++.a \
+		usr/${_target:+$CTARGET/}include/c++
 }
 
 gpp() {
 	pkgdesc="GNU C++ standard library and compiler"
-	depends="libstdc++=$_gccrel libstdc++-dev=$_gccrel gcc=$_gccrel libc-dev"
+	depends="libstdc++=$_gccrel libstdc++-dev$_target=$_gccrel gcc$_target=$_gccrel libc-dev"
 	mkdir -p "$subpkgdir/$_gcclibexec" \
 		"$subpkgdir"/usr/bin \
 		"$subpkgdir"/usr/${_target:+$CTARGET/}include \