From f08b44f0d14e073a6a57c53cd09b2d181cf3987d Mon Sep 17 00:00:00 2001
From: Timothy Legge <timlegge@gmail.com>
Date: Tue, 6 Jul 2021 23:08:13 -0300
Subject: [PATCH] main/perl-html-quoted: remove unnecessary perl-dev from
 makedepends

---
 main/perl-html-quoted/APKBUILD | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/main/perl-html-quoted/APKBUILD b/main/perl-html-quoted/APKBUILD
index 5173a43b6f25..b977de3f3ba4 100644
--- a/main/perl-html-quoted/APKBUILD
+++ b/main/perl-html-quoted/APKBUILD
@@ -8,25 +8,22 @@ url="https://metacpan.org/release/HTML-Quoted/"
 arch="noarch"
 license="GPL-2.0 or Artistic"
 depends="perl perl-html-parser"
-makedepends="perl-dev perl-module-install"
+makedepends="perl-module-install"
 subpackages="$pkgname-doc"
 source="https://cpan.metacpan.org/authors/id/T/TS/TSIBLEY/HTML-Quoted-$pkgver.tar.gz"
 
 builddir="$srcdir/HTML-Quoted-$pkgver"
 
 build() {
-	cd "$builddir"
 	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
 	make
 }
 
 check() {
-	cd "$builddir"
 	make test
 }
 
 package() {
-	cd "$builddir"
 	make DESTDIR="$pkgdir" install
 	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
 }
-- 
GitLab