From f00aec781a758491c79913d9ebe47f8530a6a234 Mon Sep 17 00:00:00 2001
From: Breno Leitao <breno.leitao@gmail.com>
Date: Mon, 10 Apr 2017 16:42:33 +0000
Subject: [PATCH] community/<go packages>: Do not compile on ppc64le

Currently ppc64le does not have go, thus, disabling the build of
the packages that depends on golang.

This patch should be reverted once we have go enabled on ppc64le.
---
 community/asciinema/APKBUILD   | 2 +-
 community/caddy/APKBUILD       | 2 +-
 community/gitea/APKBUILD       | 2 +-
 community/gomplate/APKBUILD    | 2 +-
 community/govendor/APKBUILD    | 2 +-
 community/hugo/APKBUILD        | 2 +-
 community/lego/APKBUILD        | 2 +-
 community/py-numpy/APKBUILD    | 2 +-
 community/syncthing/APKBUILD   | 2 +-
 community/syncthing13/APKBUILD | 2 +-
 10 files changed, 10 insertions(+), 10 deletions(-)

diff --git a/community/asciinema/APKBUILD b/community/asciinema/APKBUILD
index 1868ffade0e6..0c559c8e03e5 100644
--- a/community/asciinema/APKBUILD
+++ b/community/asciinema/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.2.0
 pkgrel=0
 pkgdesc="A Command line recorder for asciinema.org service"
 url="https://github.com/asciinema/asciinema/"
-arch="all !aarch64"
+arch="all !aarch64 !ppc64le"
 license="GPLv3"
 depends="curl"
 depends_dev=""
diff --git a/community/caddy/APKBUILD b/community/caddy/APKBUILD
index fcbdfef8c191..26347651138c 100644
--- a/community/caddy/APKBUILD
+++ b/community/caddy/APKBUILD
@@ -7,7 +7,7 @@ _vcheck="0.9.3"
 pkgrel=0
 pkgdesc="Fast, cross-platform HTTP/2 web server with automatic HTTPS"
 url="https://caddyserver.com/"
-arch="all"
+arch="all !ppc64le"
 license="ASL 2.0"
 depends="ca-certificates"
 makedepends="go libcap bash glide"
diff --git a/community/gitea/APKBUILD b/community/gitea/APKBUILD
index 57ca6ae48d74..1c9eb828e8fb 100644
--- a/community/gitea/APKBUILD
+++ b/community/gitea/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.1.0
 pkgrel=1
 pkgdesc="A self-hosted Git service written in Go"
 url="http://gitea.io/"
-arch="all"
+arch="all !ppc64le"
 license="MIT"
 depends="git"
 makedepends="go libcap"
diff --git a/community/gomplate/APKBUILD b/community/gomplate/APKBUILD
index fb13484a7155..5ed0a0aa1877 100644
--- a/community/gomplate/APKBUILD
+++ b/community/gomplate/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.5.1
 pkgrel=0
 pkgdesc="A versatile Go template processor"
 url="https://github.com/hairyhenderson/gomplate"
-arch="all"
+arch="all !ppc64le"
 license="MIT"
 depends="ca-certificates"
 makedepends="go"
diff --git a/community/govendor/APKBUILD b/community/govendor/APKBUILD
index 3e4bbb892022..8b42c1c74d26 100644
--- a/community/govendor/APKBUILD
+++ b/community/govendor/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.0.8
 pkgrel=1
 pkgdesc="Go vendor tool that works with the standard vendor file"
 url="https://github.com/kardianos/govendor"
-arch="all"
+arch="all !ppc64le"
 license="BSD"
 depends=""
 makedepends="go"
diff --git a/community/hugo/APKBUILD b/community/hugo/APKBUILD
index a731d793aec3..cc2bd309b110 100644
--- a/community/hugo/APKBUILD
+++ b/community/hugo/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.19
 pkgrel=0
 pkgdesc="A Fast and Flexible Static Site Generator built with love in GoLang"
 url="http://gohugo.io/"
-arch="all"
+arch="all !ppc64le"
 license="Apache 2.0"
 depends=""
 makedepends="go govendor"
diff --git a/community/lego/APKBUILD b/community/lego/APKBUILD
index fcc07c769f0a..079e43234ad6 100644
--- a/community/lego/APKBUILD
+++ b/community/lego/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.3.1
 pkgrel=1
 pkgdesc="Let's Encrypt client and ACME library written in Go"
 url="https://github.com/xenolf/lego"
-arch="all"
+arch="all !ppc64le"
 license="MIT"
 depends="ca-certificates"
 depends_dev=""
diff --git a/community/py-numpy/APKBUILD b/community/py-numpy/APKBUILD
index 68ccc95e2db3..6c7cfb9ae1cf 100644
--- a/community/py-numpy/APKBUILD
+++ b/community/py-numpy/APKBUILD
@@ -7,7 +7,7 @@ pkgver=1.12.1
 pkgrel=1
 pkgdesc="Scientific tools for Python"
 url="http://numpy.scipy.org/"
-arch="all !ppc64le"
+arch="all "
 license="BSD"
 options="!check"
 makedepends="python2-dev py-setuptools python3-dev 
diff --git a/community/syncthing/APKBUILD b/community/syncthing/APKBUILD
index cbe3cda2787f..715cc07eda97 100644
--- a/community/syncthing/APKBUILD
+++ b/community/syncthing/APKBUILD
@@ -7,7 +7,7 @@ pkgver=0.14.5
 pkgrel=0
 pkgdesc="Open Source Continuous File Synchronization"
 url="http://syncthing.net/"
-arch="all"
+arch="all !ppc64le"
 license="MPLv2"
 pkgusers="$pkgname"
 pkggroups="$pkgname"
diff --git a/community/syncthing13/APKBUILD b/community/syncthing13/APKBUILD
index 393d44dfba0f..0b8a39dbbfb8 100644
--- a/community/syncthing13/APKBUILD
+++ b/community/syncthing13/APKBUILD
@@ -8,7 +8,7 @@ pkgver=0.13.10
 pkgrel=0
 pkgdesc="Open Source Continuous File Synchronization"
 url="http://syncthing.net/"
-arch="all"
+arch="all !ppc64le"
 license="MPLv2"
 pkgusers="$_realname"
 pkggroups="$_realname"
-- 
GitLab