From eed3e0045d1eff970809c6da2a76ba2843c25585 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Wed, 24 May 2023 02:26:20 +0000
Subject: [PATCH] testing/eva: fix armv7 build

---
 testing/eva/APKBUILD   |   8 ++-
 testing/eva/deps.patch | 156 +++++++++++++++++++++++++++++++++++++++++
 2 files changed, 161 insertions(+), 3 deletions(-)
 create mode 100644 testing/eva/deps.patch

diff --git a/testing/eva/APKBUILD b/testing/eva/APKBUILD
index e4fdbacac55f..3e7649cc5844 100644
--- a/testing/eva/APKBUILD
+++ b/testing/eva/APKBUILD
@@ -2,14 +2,15 @@
 # Maintainer: Michał Polański <michal@polanski.me>
 pkgname=eva
 pkgver=0.3.1
-pkgrel=1
+pkgrel=2
 pkgdesc="Calculator REPL, similar to bc(1)"
 url="https://github.com/nerdypepper/eva"
 license="MIT"
 arch="all !s390x !riscv64" # limited by rust/cargo
 makedepends="cargo cargo-auditable"
-source="https://github.com/nerdypepper/eva/archive/v$pkgver/eva-$pkgver.tar.gz"
-
+source="https://github.com/nerdypepper/eva/archive/v$pkgver/eva-$pkgver.tar.gz
+	deps.patch
+	"
 
 prepare() {
 	default_prepare
@@ -31,4 +32,5 @@ package() {
 
 sha512sums="
 2bc6a14668f321e9dd17aab5d8e93abdc0bb4a6739365a68c33beb9f562e03e7924df0b75ad8ca8236b7c3fefc2b477b7ae8b6fe4da0ab45f40b63be4cb1e3d7  eva-0.3.1.tar.gz
+3ca527afe153d8189254dd4bcb54763e6f79a0893c97668152d407a903740898e71d26883143e13efa06233a8fc714f0776e1c139b8839bee779fdb1ea45f2e7  deps.patch
 "
diff --git a/testing/eva/deps.patch b/testing/eva/deps.patch
new file mode 100644
index 000000000000..28477d43218d
--- /dev/null
+++ b/testing/eva/deps.patch
@@ -0,0 +1,156 @@
+diff --git a/Cargo.lock b/Cargo.lock
+index 5cd799b..97623c9 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -152,7 +152,7 @@ checksum = "e11dcc7e4d79a8c89b9ab4c6f5c30b1fc4a83c420792da3542fd31179ed5f517"
+ dependencies = [
+  "cfg-if",
+  "rustix",
+- "windows-sys",
++ "windows-sys 0.36.1",
+ ]
+ 
+ [[package]]
+@@ -177,9 +177,9 @@ dependencies = [
+ 
+ [[package]]
+ name = "io-lifetimes"
+-version = "0.7.3"
++version = "0.7.5"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "1ea37f355c05dde75b84bba2d767906ad522e97cd9e2eef2be7a4ab7fb442c06"
++checksum = "59ce5ef949d49ee85593fc4d3f3f95ad61657076395cbbce23e2121fc5542074"
+ 
+ [[package]]
+ name = "libc"
+@@ -364,16 +364,16 @@ checksum = "a3f87b73ce11b1619a3c6332f45341e0047173771e8b8b73f87bfeefb7b56244"
+ 
+ [[package]]
+ name = "rustix"
+-version = "0.35.11"
++version = "0.35.13"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "fbb2fda4666def1433b1b05431ab402e42a1084285477222b72d6c564c417cef"
++checksum = "727a1a6d65f786ec22df8a81ca3121107f235970dc1705ed681d3e6e8b9cd5f9"
+ dependencies = [
+  "bitflags",
+  "errno",
+  "io-lifetimes",
+  "libc",
+  "linux-raw-sys",
+- "windows-sys",
++ "windows-sys 0.42.0",
+ ]
+ 
+ [[package]]
+@@ -442,7 +442,7 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "8440c860cf79def6164e4a0a983bcc2305d82419177a0e0c71930d049e3ac5a1"
+ dependencies = [
+  "rustix",
+- "windows-sys",
++ "windows-sys 0.36.1",
+ ]
+ 
+ [[package]]
+@@ -532,39 +532,96 @@ version = "0.36.1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "ea04155a16a59f9eab786fe12a4a450e75cdb175f9e0d80da1e17db09f55b8d2"
+ dependencies = [
+- "windows_aarch64_msvc",
+- "windows_i686_gnu",
+- "windows_i686_msvc",
+- "windows_x86_64_gnu",
+- "windows_x86_64_msvc",
++ "windows_aarch64_msvc 0.36.1",
++ "windows_i686_gnu 0.36.1",
++ "windows_i686_msvc 0.36.1",
++ "windows_x86_64_gnu 0.36.1",
++ "windows_x86_64_msvc 0.36.1",
+ ]
+ 
++[[package]]
++name = "windows-sys"
++version = "0.42.0"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "5a3e1820f08b8513f676f7ab6c1f99ff312fb97b553d30ff4dd86f9f15728aa7"
++dependencies = [
++ "windows_aarch64_gnullvm",
++ "windows_aarch64_msvc 0.42.2",
++ "windows_i686_gnu 0.42.2",
++ "windows_i686_msvc 0.42.2",
++ "windows_x86_64_gnu 0.42.2",
++ "windows_x86_64_gnullvm",
++ "windows_x86_64_msvc 0.42.2",
++]
++
++[[package]]
++name = "windows_aarch64_gnullvm"
++version = "0.42.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "597a5118570b68bc08d8d59125332c54f1ba9d9adeedeef5b99b02ba2b0698f8"
++
+ [[package]]
+ name = "windows_aarch64_msvc"
+ version = "0.36.1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "9bb8c3fd39ade2d67e9874ac4f3db21f0d710bee00fe7cab16949ec184eeaa47"
+ 
++[[package]]
++name = "windows_aarch64_msvc"
++version = "0.42.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "e08e8864a60f06ef0d0ff4ba04124db8b0fb3be5776a5cd47641e942e58c4d43"
++
+ [[package]]
+ name = "windows_i686_gnu"
+ version = "0.36.1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "180e6ccf01daf4c426b846dfc66db1fc518f074baa793aa7d9b9aaeffad6a3b6"
+ 
++[[package]]
++name = "windows_i686_gnu"
++version = "0.42.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "c61d927d8da41da96a81f029489353e68739737d3beca43145c8afec9a31a84f"
++
+ [[package]]
+ name = "windows_i686_msvc"
+ version = "0.36.1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "e2e7917148b2812d1eeafaeb22a97e4813dfa60a3f8f78ebe204bcc88f12f024"
+ 
++[[package]]
++name = "windows_i686_msvc"
++version = "0.42.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "44d840b6ec649f480a41c8d80f9c65108b92d89345dd94027bfe06ac444d1060"
++
+ [[package]]
+ name = "windows_x86_64_gnu"
+ version = "0.36.1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "4dcd171b8776c41b97521e5da127a2d86ad280114807d0b2ab1e462bc764d9e1"
+ 
++[[package]]
++name = "windows_x86_64_gnu"
++version = "0.42.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "8de912b8b8feb55c064867cf047dda097f92d51efad5b491dfb98f6bbb70cb36"
++
++[[package]]
++name = "windows_x86_64_gnullvm"
++version = "0.42.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "26d41b46a36d453748aedef1486d5c7a85db22e56aff34643984ea85514e94a3"
++
+ [[package]]
+ name = "windows_x86_64_msvc"
+ version = "0.36.1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "c811ca4a8c853ef420abd8592ba53ddbbac90410fab6903b3e79972a631f7680"
++
++[[package]]
++name = "windows_x86_64_msvc"
++version = "0.42.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++checksum = "9aec5da331524158c6d1a4ac0ab1541149c0b9505fde06423b02f5ef0106b9f0"
-- 
GitLab