Commit ec709bf0 authored by rubicon's avatar rubicon
Browse files

testing/pike: fix compatibility with zlib 1.2.12

parent dbe85431
......@@ -29,7 +29,9 @@ makedepends="gmp-dev
zlib-dev
librsvg-dev"
subpackages="$pkgname-doc $pkgname-full::noarch"
source="$pkgname-$pkgver.tar.gz::https://pike.lysator.liu.se/pub/pike/all/$pkgver/$_pkgname-v$pkgver.tar.gz"
source="$pkgname-$pkgver.tar.gz::https://pike.lysator.liu.se/pub/pike/all/$pkgver/$_pkgname-v$pkgver.tar.gz
zlib-1.2.12-test.patch
"
builddir="$srcdir/$_pkgname-v$pkgver"
_full_deps="$pkgname=$pkgver-r$pkgrel $pkgname-doc=$pkgver-r$pkgrel"
......@@ -161,4 +163,5 @@ full() {
sha512sums="
6c42594e7cd52fac124068014926e4eb6edcbbb44c51bf806db6b0d0514c710f8c19352813a78b0e2ae8032f40315f72d0990eeaefe6a1f97578ec5045e650d2 pike-8.0.1738.tar.gz
9bef9e95a8beb02b030a29c189216be2b58b3ac12976c3ec44b53305a4bde360e69176061179678a1e519458212c7d8636adef37fd9a3a4dcc3a057520920eb8 zlib-1.2.12-test.patch
"
Adapted from test/example.c diff of https://github.com/madler/zlib/commit/0d36ec4
--- a/src/modules/Gz/gz_test.c
+++ b/src/modules/Gz/gz_test.c
@@ -321,9 +321,8 @@
CHECK_ERR(err, "inflateSync");
err = inflate(&d_stream, Z_FINISH);
- if (err != Z_DATA_ERROR) {
- fprintf(stderr, "inflate should report DATA_ERROR\n");
- /* Because of incorrect adler32 */
+ if (err != Z_STREAM_END) {
+ fprintf(stderr, "inflate should report Z_STREAM_END\n");
exit(1);
}
err = inflateEnd(&d_stream);
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment