diff --git a/testing/nushell/APKBUILD b/testing/nushell/APKBUILD
index 9dbc20fb96e48c4f6895199eafd595243730ae0d..d95e1d175d7a9e834d605f3958c721dd2424e0b0 100644
--- a/testing/nushell/APKBUILD
+++ b/testing/nushell/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: nibon7 <nibon7@163.com>
 # Maintainer: nibon7 <nibon7@163.com>
 pkgname=nushell
-pkgver=0.84.0
+pkgver=0.85.0
 pkgrel=0
 pkgdesc="A new type of shell"
 url="https://www.nushell.sh"
@@ -69,6 +69,6 @@ _plugins() {
 }
 
 sha512sums="
-d3bd4b312a86a604e738cf7e0da8931de255858e0f2f430e28afa7af93203845c8e559bf944b966d6f18e837b6a589cc3d0372a58425940432e59096ed564e78  nushell-0.84.0.tar.gz
-18f778c6118305b9accb592d017f0a5c085f9abfcbec57388b9b8c2787ec1b00a3c4155c7979ebcb4800a63fa7eafc45943fa3ea7a727788de789bbe9294f042  system-deps.patch
+d8118b40c181290c918ed07acc85e4ddd603a6a517c66ac1b3dc161285d281b38282f35ca24a6b2720b5dac2582ca63a8c376d50a8b3b08a0830b8bc54b03d89  nushell-0.85.0.tar.gz
+5b97aee3d7e995733e3659b5bcb350af38a42d009acdcf38cadb428fb23138a10ed71664deb889e1f25552e3e50e7ccc36798a01aa2384d1079cea5cea6c8326  system-deps.patch
 "
diff --git a/testing/nushell/system-deps.patch b/testing/nushell/system-deps.patch
index e1b0d09a3da279825273609e0b9db0694fc85894..e85e24016a32d5802a2d1b74ffcaf49e5002e6e7 100644
--- a/testing/nushell/system-deps.patch
+++ b/testing/nushell/system-deps.patch
@@ -1,8 +1,8 @@
 diff --git a/Cargo.lock b/Cargo.lock
-index 45c2396..6021614 100644
+index f46dd56..ad9ecfb 100644
 --- a/Cargo.lock
 +++ b/Cargo.lock
-@@ -2087,7 +2087,6 @@ version = "0.26.0"
+@@ -2236,7 +2236,6 @@ version = "0.26.0"
  source = "registry+https://github.com/rust-lang/crates.io-index"
  checksum = "afc22eff61b133b115c6e8c74e818c628d6d5e7a502afea6f64dee076dd94326"
  dependencies = [
@@ -11,36 +11,36 @@ index 45c2396..6021614 100644
   "vcpkg",
  ]
 diff --git a/Cargo.toml b/Cargo.toml
-index 8550e24..068d3f8 100644
+index ab87f9e..8ad69db 100644
 --- a/Cargo.toml
 +++ b/Cargo.toml
-@@ -67,7 +67,7 @@ nu-term-grid = { path = "./crates/nu-term-grid", version = "0.83.0" }
- nu-std = { path = "./crates/nu-std", version = "0.83.0" }
- nu-utils = { path = "./crates/nu-utils", version = "0.83.0" }
+@@ -67,7 +67,7 @@ nu-term-grid = { path = "./crates/nu-term-grid", version = "0.85.0" }
+ nu-std = { path = "./crates/nu-std", version = "0.85.0" }
+ nu-utils = { path = "./crates/nu-utils", version = "0.85.0" }
  nu-ansi-term = "0.49.0"
--reedline = { version = "0.23.0", features = ["bashisms", "sqlite"]}
-+reedline = { version = "0.23.0", features = ["bashisms", "sqlite-dynlib"]}
- 
- mimalloc = { version = "0.1.37", default-features = false, optional = true}
+-reedline = { version = "0.24.0", features = ["bashisms", "sqlite"] }
++reedline = { version = "0.24.0", features = ["bashisms", "sqlite-dynlib"]}
  
+ crossterm = "0.27"
+ ctrlc = "3.4"
 diff --git a/crates/nu-cli/Cargo.toml b/crates/nu-cli/Cargo.toml
-index b85c419..68da2b8 100644
+index 5b7fda5..476694e 100644
 --- a/crates/nu-cli/Cargo.toml
 +++ b/crates/nu-cli/Cargo.toml
-@@ -25,7 +25,7 @@ nu-protocol = { path = "../nu-protocol", version = "0.83.0" }
- nu-utils = { path = "../nu-utils", version = "0.83.0" }
- nu-color-config = { path = "../nu-color-config", version = "0.83.0" }
+@@ -25,7 +25,7 @@ nu-protocol = { path = "../nu-protocol", version = "0.85.0" }
+ nu-utils = { path = "../nu-utils", version = "0.85.0" }
+ nu-color-config = { path = "../nu-color-config", version = "0.85.0" }
  nu-ansi-term = "0.49.0"
--reedline = { version = "0.23.0", features = ["bashisms", "sqlite"]}
-+reedline = { version = "0.23.0", features = ["bashisms", "sqlite-dynlib"]}
+-reedline = { version = "0.24.0", features = ["bashisms", "sqlite"] }
++reedline = { version = "0.24.0", features = ["bashisms", "sqlite-dynlib"]}
  
  chrono = { default-features = false, features = ["std"], version = "0.4" }
- crossterm = "0.26"
+ crossterm = "0.27"
 diff --git a/crates/nu-command/Cargo.toml b/crates/nu-command/Cargo.toml
-index b84a3dc..8ae059e 100644
+index 2f26bcb..9c7c29c 100644
 --- a/crates/nu-command/Cargo.toml
 +++ b/crates/nu-command/Cargo.toml
-@@ -75,7 +75,7 @@ rand = "0.8"
+@@ -73,7 +73,7 @@ rand = "0.8"
  rayon = "1.7"
  regex = "1.7"
  roxmltree = "0.18"