diff --git a/community/althttpd/10-allow-filename-plus-sign.patch b/community/althttpd/10-allow-filename-plus-sign.patch
index ba9228fdf6aa4fb682e3f2c37bfef081b63f62f2..2e51f9912729f0525b6e49c0dcf1c019b8ecea6f 100644
--- a/community/althttpd/10-allow-filename-plus-sign.patch
+++ b/community/althttpd/10-allow-filename-plus-sign.patch
@@ -4,7 +4,7 @@ adds the plus sign (0x2b) to the list of characters allowed by upstream
 which are 0-9a-zA-Z,-./:_~
 --- src/althttpd.c.orig
 +++ src/althttpd.c
-@@ -1827,7 +1827,7 @@
+@@ -1860,7 +1860,7 @@
        /*  x0  x1  x2  x3  x4  x5  x6  x7  x8  x9  xa  xb  xc  xd  xe  xf */
  /* 0x */   0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,
  /* 1x */   0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,
diff --git a/community/althttpd/APKBUILD b/community/althttpd/APKBUILD
index a0853587d0c19213a1271d937dfbcfff87cf1126..05fbf8b0c6a9c61931d97c62bc1f55a4b760ddd0 100644
--- a/community/althttpd/APKBUILD
+++ b/community/althttpd/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Sodface <sod@sodface.com>
 # Maintainer: Sodface <sod@sodface.com>
 pkgname=althttpd
-pkgver=202205172045
+pkgver=202206041050
 pkgrel=0
 pkgdesc="Small, simple, stand-alone HTTP server"
 url="https://sqlite.org/althttpd/doc/trunk/althttpd.md"
@@ -34,8 +34,8 @@ package() {
 }
 
 sha512sums="
-54e4ae6e85fd341a88e232700e5b867854eb52e3e74a5e56800806ebcbe1eac7e556832dc465ba9e3417828a20860d8e2c193b1992207c7625def46e91ecdf75  althttpd-202205172045.tar.gz
-37b5c394b33c3b5e0ff93ae951610bf86ecbf877ae5b267d25c6f188cf60c853220399f8f87f119c0f6f6513e8a82d21e5643d08631aa0702e704554b803ced3  10-allow-filename-plus-sign.patch
-4418cd6431dccc2a51866d0a6b486166de4ea4752fcdadd41b2605ac7f4fbc49af076cc48ef1cafb38dfceef22c4e1cabd4b160ec2e2f4871b39c33680440a5b  althttpd.confd
+56c6e9ad23d9b80f2d72ab36f5b7c3d2875c77057a3544b7d11c9bacf70e21f9801b6fdd48356415a09b60b4b32678dea39c31e2d7feb45cb3c333a578a4ecf1  althttpd-202206041050.tar.gz
+f1b7e7be0ffe9ec15313fe70c5080cbc742917b594b410b2f3016a63ac46071d8d2cb3f071c4809b8076ea836ddd11c0197a2a216568611a66492ad01d76c929  10-allow-filename-plus-sign.patch
+6ad8e0d3227773eda5f4d32dee8de8fd3aa590f32fb7b6f6fb13855b6576e5faa1578a1d363c0b846323a723998958fcef9c4c1359d23c183a750b07a00079cd  althttpd.confd
 f21867430470b836d97d60215d9dda835125140cced3bb9c856349228572f2c73ac0574d3f705d72938879fc2b5a37855768a5f7de5c29943e3aa6ead5d72d9c  althttpd.initd
 "
diff --git a/community/althttpd/althttpd.confd b/community/althttpd/althttpd.confd
index 81b67e058240551fcee2e863a3efaa9520f2b925..62b1f2b9825b40fef9acc6495b17867a7a3d3b10 100644
--- a/community/althttpd/althttpd.confd
+++ b/community/althttpd/althttpd.confd
@@ -9,7 +9,8 @@
 #**                   This option is required for xinetd launch but defaults
 #**                   to "." for a stand-alone web server.
 #**
-#**  --port N         Run in standalone mode listening on TCP port N
+#**  --port N         Run in standalone mode listening on TCP port N, or from
+#**  --port N1..N2    the first available TCP port in the range from N1 to N2.
 #**
 #**  --user USER      Define the user under which the process should run if
 #**                   originally launched as root.  This process will refuse to
@@ -39,6 +40,15 @@
 #**                   does *not* activate built-in TLS support.  Use --cert
 #**                   for that.
 #**
+#**  --page NAME      Come up in stand-alone mode, and then try to launch a
+#**                   web-browser pointing to the NAME document after the
+#**                   listening socket has been created.  This option
+#**                   implies --loopback and "--port 8080..8100".
+#**
+#**  --loopback       Only accept loop-back TCP connections (connections
+#**                   originating from the same host).  This is the
+#**                   default if --root is omitted.
+#**
 #**  --family ipv4    Only accept input from IPV4 or IPV6, respectively.
 #**  --family ipv6    These options are only meaningful if althttpd is run
 #**                   as a stand-alone server.