diff --git a/community/wlroots0.12/0001-Revert-layer-shell-error-on-0-dimension-without-anch.patch b/community/wlroots0.12/0001-Revert-layer-shell-error-on-0-dimension-without-anch.patch
new file mode 100644
index 0000000000000000000000000000000000000000..15d492cd0c9910c122ddab6136ab5ebf9121298d
--- /dev/null
+++ b/community/wlroots0.12/0001-Revert-layer-shell-error-on-0-dimension-without-anch.patch
@@ -0,0 +1,51 @@
+Upstream: no
+
+From e43ba0857cb39eae30b5e02cb87723e6456dc61e Mon Sep 17 00:00:00 2001
+From: Oliver Smith <ollieparanoid@postmarketos.org>
+Date: Tue, 10 Nov 2020 20:57:04 +0100
+Subject: [PATCH] Revert "layer-shell: error on 0 dimension without anchors"
+
+This reverts commit 8dec751a6d84335fb04288b8efab6dd5c90288d3, which
+introduced a consistency check:
+https://github.com/swaywm/wlroots/commit/8dec751a6d84335fb04288b8efab6dd5c90288d3
+
+Currently this causes phosh to crash, so let's revert it temporarily:
+https://source.puri.sm/Librem5/phosh/-/issues/422
+---
+ types/wlr_layer_shell_v1.c | 20 --------------------
+ 1 file changed, 20 deletions(-)
+
+diff --git a/types/wlr_layer_shell_v1.c b/types/wlr_layer_shell_v1.c
+index bc681117..d83b22b8 100644
+--- a/types/wlr_layer_shell_v1.c
++++ b/types/wlr_layer_shell_v1.c
+@@ -307,26 +307,6 @@ static void layer_surface_role_commit(struct wlr_surface *wlr_surface) {
+ 		return;
+ 	}
+ 
+-	const uint32_t horiz = ZWLR_LAYER_SURFACE_V1_ANCHOR_LEFT |
+-		ZWLR_LAYER_SURFACE_V1_ANCHOR_RIGHT;
+-	if (surface->client_pending.desired_width == 0 &&
+-		(surface->client_pending.anchor & horiz) != horiz) {
+-		wl_resource_post_error(surface->resource,
+-			ZWLR_LAYER_SURFACE_V1_ERROR_INVALID_SIZE,
+-			"width 0 requested without setting left and right anchors");
+-		return;
+-	}
+-
+-	const uint32_t vert = ZWLR_LAYER_SURFACE_V1_ANCHOR_TOP |
+-		ZWLR_LAYER_SURFACE_V1_ANCHOR_BOTTOM;
+-	if (surface->client_pending.desired_height == 0 &&
+-		(surface->client_pending.anchor & vert) != vert) {
+-		wl_resource_post_error(surface->resource,
+-			ZWLR_LAYER_SURFACE_V1_ERROR_INVALID_SIZE,
+-			"height 0 requested without setting top and bottom anchors");
+-		return;
+-	}
+-
+ 	if (surface->closed) {
+ 		// Ignore commits after the compositor has closed it
+ 		return;
+-- 
+2.20.1
+
diff --git a/community/wlroots0.12/APKBUILD b/community/wlroots0.12/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..3f491b19a931419c6c8a4b902b90627400e5448a
--- /dev/null
+++ b/community/wlroots0.12/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Contributor: Drew DeVault <sir@cmpwn.com>
+pkgname=wlroots0.12
+pkgver=0.12.0
+pkgrel=0
+pkgdesc="modular Wayland compositor library (version 0.12.0 for phoc)"
+url="https://github.com/swaywm/wlroots"
+arch="all"
+license="MIT"
+options="!check" # contains no test suite
+makedepends="
+	elogind-dev
+	eudev-dev
+	libcap-dev
+	libinput-dev
+	libxcb-dev
+	libxkbcommon-dev
+	mesa-dev
+	meson
+	ninja
+	pixman-dev
+	wayland-dev
+	wayland-protocols
+	xcb-util-image-dev
+	xcb-util-wm-dev
+	xkeyboard-config
+	"
+subpackages="$pkgname-dbg $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/wlroots/archive/$pkgver.tar.gz
+	0001-Revert-layer-shell-error-on-0-dimension-without-anch.patch
+	"
+builddir="$srcdir/wlroots-$pkgver"
+
+build() {
+	abuild-meson \
+		-Dlogind=enabled \
+		-Dlogind-provider=elogind \
+		-Dexamples=false \
+		. build
+	meson compile ${JOBS:+-j ${JOBS}} -C build
+}
+
+package() {
+	DESTDIR="$pkgdir" meson install --no-rebuild -C build
+}
+
+sha512sums="
+560eae30932b777c1f07fb44592d5601c5d10ef74b31b6b9e4166a14caadab2bfa88d39282f159785d4c7f22f78d204f9bb7fab65d58afaf14b72a8486f9b415  wlroots0.12-0.12.0.tar.gz
+5547741b35fc8364360dabb93a6f988b6be9299b77ee4adf2c7edfcd4a3c97f2f0cbbd19a41548254fe5d2327ed45300824920ce3c9d0cb0846a3ba5b5a83e02  0001-Revert-layer-shell-error-on-0-dimension-without-anch.patch
+"