Commit e87b2836 authored by tcely's avatar tcely Committed by Leonardo Arena
Browse files

testing/knot-resolver: depend on lua5.1-http

parent 0ff6c91e
...@@ -13,7 +13,7 @@ pkggroups="kresd" ...@@ -13,7 +13,7 @@ pkggroups="kresd"
depends="lua5.1-sec lua5.1-socket" depends="lua5.1-sec lua5.1-socket"
depends_dnstap="" depends_dnstap=""
depends_dnstap_dev="fstrm-dev protobuf-c-dev" depends_dnstap_dev="fstrm-dev protobuf-c-dev"
depends_http="$pkgname" depends_http="$pkgname lua5.1-http"
depends_dev="knot-dev libedit-dev libuv-dev luajit-dev $depends_dnstap_dev" depends_dev="knot-dev libedit-dev libuv-dev luajit-dev $depends_dnstap_dev"
makedepends="$depends_dev bash vim" makedepends="$depends_dev bash vim"
checkdepends="cmocka-dev" checkdepends="cmocka-dev"
...@@ -67,7 +67,6 @@ package() { ...@@ -67,7 +67,6 @@ package() {
install -m 644 -D "$srcdir"/$pkgname.logrotate ./etc/logrotate.d/$pkgname install -m 644 -D "$srcdir"/$pkgname.logrotate ./etc/logrotate.d/$pkgname
} }
# TODO: depends on https://github.com/daurnimator/lua-http!
http() { http() {
pkgdesc="Knot Resolver - HTTP/2 services" pkgdesc="Knot Resolver - HTTP/2 services"
depends="$depends_http" depends="$depends_http"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment