From e5fe71e16a0271b5b00ff4b095872f43da2deadb Mon Sep 17 00:00:00 2001
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Sun, 22 May 2022 17:24:28 +0200
Subject: [PATCH] community/suitesparse: upgrade to 5.10.1

This is not the latest available version (that's 5.12.0), but the one
used in Julia. There's some issue with building 5.12.0, so I will
upgrade to this later.
---
 community/suitesparse/APKBUILD | 31 ++++++++++++++++++++++++-------
 1 file changed, 24 insertions(+), 7 deletions(-)

diff --git a/community/suitesparse/APKBUILD b/community/suitesparse/APKBUILD
index bfa28b5cff8b..3d70fce94d92 100644
--- a/community/suitesparse/APKBUILD
+++ b/community/suitesparse/APKBUILD
@@ -2,16 +2,24 @@
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=suitesparse
 _pkgname=SuiteSparse
-pkgver=5.6.0
-pkgrel=3
+pkgver=5.10.1
+pkgrel=0
 pkgdesc="A collection of sparse matrix libraries"
 url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
 arch="all"
 license="GPL-3.0-only"
-depends_dev="openblas-dev"
+depends_dev="
+	gmp-dev
+	mpfr-dev
+	openblas-dev
+	"
 makedepends="$depends_dev cmake m4"
-subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver.tar.gz
+subpackages="
+	$pkgname-dev
+	$pkgname-doc
+	$pkgname-graphblas
+	"
+source="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver/$_pkgname-$pkgver.tar.gz
 	0001-exclude-metis.patch
 	0002-remove-rpath.patch
 	"
@@ -51,6 +59,15 @@ package() {
 		INSTALL_LIB="$pkgdir"/usr/lib
 }
 
-sha512sums="c4dac62710501388fd58e52fe239723f83a94ff666410f711d42710485730d2821d3bb0ad937b40ac1a257e6da2ed317e30d74592b16ac3f959295965314d6dc  suitesparse-5.6.0.tar.gz
+graphblas() {
+	pkgdesc="Graph algorithms in the language of linear algebra"
+	license="Apache-2.0"
+
+	amove usr/lib/libgraphblas.so.*
+}
+
+sha512sums="
+8f85c6d63b76cba95707dfa732c51200df7794cb4c2599dbd92100475747b8d02b05089a47096e85c60b89bc852a8e768e0670f24902a82d29494a80ccf2bb5f  SuiteSparse-5.10.1.tar.gz
 0bdaed29c7770104eb94d9e60a42fe68b5643c8f958aba4cc6d7996888a83ae75a4e509d0c262264c49d5d9b1ca23a958cc71cfaa5e983b0008e65455a987cac  0001-exclude-metis.patch
-cd40b696515b26c95298b435a5111e582dc42c2fa2e8ef9889558467d375b1d19452838b9463df66958e73ddb0c8c0191936e3e952586a3c7d345edb08fa7e62  0002-remove-rpath.patch"
+cd40b696515b26c95298b435a5111e582dc42c2fa2e8ef9889558467d375b1d19452838b9463df66958e73ddb0c8c0191936e3e952586a3c7d345edb08fa7e62  0002-remove-rpath.patch
+"
-- 
GitLab